summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
-rw-r--r--makefile.patch29
3 files changed, 27 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4e0fe183104..df93debf0256 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pachi
pkgdesc = A reasonably strong engine for the board game go
- pkgver = 12.70
+ pkgver = 12.82
pkgrel = 1
url = http://pachi.or.cz/
arch = i686
@@ -8,10 +8,9 @@ pkgbase = pachi
license = GPL
depends = glibc
options = !makeflags
- source = https://github.com/pasky/pachi/archive/pachi-12.70.tar.gz
+ source = https://github.com/pasky/pachi/archive/pachi-12.82.tar.gz
source = makefile.patch
- sha256sums = 5c5f081fec5ff6ad984f75c32c4c5b3d7d5b9dc5677a8058d9146b35fa922733
- sha256sums = 19f5d74457d506198ad3ea95ff2fc3c3f9737ed0340f5178b1ba8ebd7fe62fc6
+ sha256sums = 1920c3f58b07cb50f7dc38d52485a26990279343119225c6302768840047f507
+ sha256sums = 3a9d02d554f217c245dcae78d181acd99b35b58f22b66248b7768a2eab9dd0dd
pkgname = pachi
-
diff --git a/PKGBUILD b/PKGBUILD
index 62f15b882d56..0eb48810ba48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=pachi
-pkgver=12.70
+pkgver=12.82
pkgrel=1
pkgdesc="A reasonably strong engine for the board game go"
arch=('i686' 'x86_64')
@@ -10,8 +10,8 @@ depends=('glibc')
url="http://pachi.or.cz/"
license=('GPL')
source=("https://github.com/pasky/pachi/archive/$pkgname-$pkgver.tar.gz" makefile.patch)
-sha256sums=('5c5f081fec5ff6ad984f75c32c4c5b3d7d5b9dc5677a8058d9146b35fa922733'
- '19f5d74457d506198ad3ea95ff2fc3c3f9737ed0340f5178b1ba8ebd7fe62fc6')
+sha256sums=('1920c3f58b07cb50f7dc38d52485a26990279343119225c6302768840047f507'
+ '3a9d02d554f217c245dcae78d181acd99b35b58f22b66248b7768a2eab9dd0dd')
options=('!makeflags')
prepare() {
@@ -21,11 +21,11 @@ prepare() {
build() {
cd $pkgname-$pkgname-$pkgver
- make
+ make DCNN=0
}
package() {
cd $pkgname-$pkgname-$pkgver
install -d "$pkgdir"/usr/bin
- make PREFIX="$pkgdir"/usr install
+ make DCNN=0 PREFIX="$pkgdir"/usr install
}
diff --git a/makefile.patch b/makefile.patch
index 42b0499d87e4..3edf8a3f7307 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -1,16 +1,23 @@
-diff -Naur pachi-pachi-12.10-jowa.orig/Makefile pachi-pachi-12.10-jowa.new/Makefile
---- pachi-pachi-12.10-jowa.orig/Makefile 2018-08-14 19:45:14.946828806 +0200
-+++ pachi-pachi-12.10-jowa.new/Makefile 2018-08-14 19:46:53.610162808 +0200
-@@ -28,7 +28,7 @@
- # You'll need to install Boost and Caffe libraries.
- # If Caffe is in a custom directory you can set it here.
+--- pachi-pachi-12.82/Makefile 2023-07-05 04:25:05.000000000 +0200
++++ pachi-pachi-12.82.new/Makefile 2023-08-18 23:50:06.538581419 +0200
+@@ -207,6 +207,7 @@
--DCNN=1
-+DCNN=0
- # CAFFE_PREFIX=/usr/local/caffe
+ ifeq ($(DCNN_DETLEF), 1)
+ COMMON_FLAGS += -DDCNN_DETLEF
++ EXTRA_DATAFILES += detlef54.prototxt detlef54.trained
+ endif
- # Fixed board size. Set this to enable more aggressive optimizations
-@@ -319,7 +319,7 @@
+ ifeq ($(DCNN_DARKFOREST), 1)
+@@ -284,7 +285,7 @@
+
+ # Low-level dependencies last
+ SUBDIRS = $(EXTRA_SUBDIRS) pattern joseki uct uct/policy t-unit t-predict engines playout tactics
+-DATAFILES = $(EXTRA_DATAFILES) detlef54.prototxt detlef54.trained joseki19.gtp opening.dat patterns_mm.gamma patterns_mm.spat
++DATAFILES = $(EXTRA_DATAFILES) joseki19.gtp patterns_mm.gamma patterns_mm.spat
+
+
+ ############################################################################################################
+@@ -310,7 +311,7 @@
@CC="$(CC)" CFLAGS="$(CFLAGS)" ./spudfrog
# Build info