summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--[l---------]PKGBUILD32
2 files changed, 32 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d4cc9d7a4e9..e1a86d018fe8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,7 @@
pkgbase = pacman-history
pkgdesc = get pacman history for one file
pkgver = 0.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/papajoker/pacman-history
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 7a5446a0467f..895ec00dba89 120000..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1 +1,31 @@
-/home/patrick/workspace/bash/pacman-history/src/PKGBUILD \ No newline at end of file
+# Maintainer: Papajoker <papajoker [at] archlinux [dot] info>
+pkgname=pacman-history
+pkgver=0.2.0
+pkgrel=2
+pkgdesc="get pacman history for one file"
+arch=('any')
+url="https://github.com/papajoker/pacman-history"
+license=('GPL')
+groups=()
+depends=('pacman')
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("$pkgname::git+http://github.com/papajoker/pacman-history#branch=master")
+noextract=()
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir"
+ msg "Starting build..."
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 ./${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ install -Dm644 ./${pkgname}.fr ${pkgdir}/usr/share/locale/fr/LC_MESSAGES/${pkgname}
+}