summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
-rw-r--r--pacman4console.6 (renamed from pacman4console)0
-rw-r--r--pacman4console.patch143
-rw-r--r--pacman4consoleedit.1 (renamed from pacman4consoleedit)0
5 files changed, 58 insertions, 115 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d778af84df85..68333cb12da3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
+# Generated by mksrcinfo v8
+# Tue Oct 24 11:51:07 UTC 2017
pkgbase = pacman4console
pkgdesc = A 9 level ncurses pacman game with editor, patched not to disturb our package manager and to have nice ghosts
- pkgver = 1.2
+ pkgver = 1.3
pkgrel = 1
url = http://sites.google.com/site/doctormike/pacman.html
arch = i686
arch = x86_64
license = GPL
depends = ncurses
- source = http://ftp.debian.org/debian/pool/main/p/pacman4console/pacman4console_1.2.orig.tar.gz
+ source = http://ftp.debian.org/debian/pool/main/p/pacman4console/pacman4console_1.3.orig.tar.gz
source = pacman4console.patch
- source = pacman4console
- source = pacman4consoleedit
- md5sums = 1568960898ad9cb66c77412b85cd7d86
- md5sums = fdd2bd5b2d7f2a4afa5634146449288c
+ source = pacman4console.6
+ source = pacman4consoleedit.1
+ md5sums = 015ca457e3d3a4ceb62673edd6fb3e78
+ md5sums = f01c6424a9339bef3046627e2af78654
md5sums = b913fb9959f2988a41457c270eb0d3b3
md5sums = fc43203fcbc5b27872131ac6dfe85ddc
diff --git a/PKGBUILD b/PKGBUILD
index 9c22529e1b79..a5fa00250146 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Erus <erus.iluvatar@gmail.com>
pkgname=pacman4console
-pkgver=1.2
+pkgver=1.3
pkgrel=1
pkgdesc="A 9 level ncurses pacman game with editor, patched not to disturb our package manager and to have nice ghosts"
arch=('i686' 'x86_64')
@@ -8,11 +8,11 @@ url="http://sites.google.com/site/doctormike/pacman.html"
license=('GPL')
depends=('ncurses')
makedepends=()
-source=('http://ftp.debian.org/debian/pool/main/p/pacman4console/pacman4console_1.2.orig.tar.gz' 'pacman4console.patch' 'pacman4console' 'pacman4consoleedit')
-md5sums=('1568960898ad9cb66c77412b85cd7d86'
- 'fdd2bd5b2d7f2a4afa5634146449288c'
- 'b913fb9959f2988a41457c270eb0d3b3'
- 'fc43203fcbc5b27872131ac6dfe85ddc')
+source=("http://ftp.debian.org/debian/pool/main/p/pacman4console/${pkgname}_${pkgver}.orig.tar.gz" 'pacman4console.patch' 'pacman4console.6' 'pacman4consoleedit.1')
+md5sums=('015ca457e3d3a4ceb62673edd6fb3e78'
+ 'f01c6424a9339bef3046627e2af78654'
+ 'b913fb9959f2988a41457c270eb0d3b3'
+ 'fc43203fcbc5b27872131ac6dfe85ddc')
build() {
cd pacman-$pkgver/
@@ -24,6 +24,6 @@ package() {
cd pacman-$pkgver/
make DESTDIR=$pkgdir install || return 1
install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
- install -D -m644 ../pacman4console $pkgdir/usr/share/man/man6/pacman4console.6
- install -D -m644 ../pacman4consoleedit $pkgdir/usr/share/man/man1/pacman4consoleedit.1
+ install -D -m644 ../pacman4console.6 $pkgdir/usr/share/man/man6/pacman4console.6
+ install -D -m644 ../pacman4consoleedit.1 $pkgdir/usr/share/man/man1/pacman4consoleedit.1
}
diff --git a/pacman4console b/pacman4console.6
index f4f52abb5553..f4f52abb5553 100644
--- a/pacman4console
+++ b/pacman4console.6
diff --git a/pacman4console.patch b/pacman4console.patch
index 0889affafc1a..718fc6d3239d 100644
--- a/pacman4console.patch
+++ b/pacman4console.patch
@@ -1,107 +1,48 @@
---- Makefile 2009-12-22 13:23:44.086853403 +0100
-+++ Makefile.new 2009-12-22 13:26:21.380175264 +0100
-@@ -1,17 +1,17 @@
+--- Makefile.orig 2017-10-24 13:38:53.179171635 +0200
++++ Makefile 2017-10-24 13:40:58.242422264 +0200
+@@ -1,20 +1,21 @@
+-prefix=/usr/local
++prefix=/usr
+ bindir=$(prefix)/bin
+ datarootdir=$(prefix)/share
+
all:
-- gcc -lncurses pacman.c -o pacman
-- gcc -lncurses pacmanedit.c -o pacmanedit
-+ gcc -lncurses pacman.c -o pacman4console
-+ gcc -lncurses pacmanedit.c -o pacman4consoleedit
+- gcc pacman.c -o pacman -DDATAROOTDIR=\"$(datarootdir)\" $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -lncurses
+- gcc pacmanedit.c -o pacmanedit -DDATAROOTDIR=\"$(datarootdir)\" $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -lncurses
++ gcc pacman.c -o pacman4console -DDATAROOTDIR=\"$(datarootdir)\" $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -lncurses -ltinfo
++ gcc pacmanedit.c -o pacman4consoleedit -DDATAROOTDIR=\"$(datarootdir)\" $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -lncurses -ltinfo
- install: all
-- cp pacman /usr/local/bin
-- cp pacmanedit /usr/local/bin
-- mkdir -p /usr/local/share/pacman
-- cp -fR Levels/ /usr/local/share/pacman/
-- chown root:games /usr/local/bin/pacman
-- chown root:games /usr/local/share/pacman -R
-- chmod 750 /usr/local/bin/pacman
-- chmod 750 /usr/local/bin/pacmanedit
-- chmod 750 /usr/local/share/pacman/ -R
-+ install -D pacman4console $(DESTDIR)/usr/bin/pacman4console
-+ install -D pacman4consoleedit $(DESTDIR)/usr/bin/pacman4consoleedit
-+ mkdir -p $(DESTDIR)/usr/share/pacman4console
-+ cp -fR Levels/ $(DESTDIR)/usr/share/pacman4console/
-+ chown root:games $(DESTDIR)/usr/bin/pacman4console
-+ chown root:games $(DESTDIR)/usr/share/pacman4console -R
-+ chmod 755 $(DESTDIR)/usr/bin/pacman4console
-+ chmod 755 $(DESTDIR)/usr/bin/pacman4consoleedit
-+ chmod 755 $(DESTDIR)/usr/share/pacman4console/ -R
+ install: all
+ mkdir -p $(DESTDIR)$(bindir)
+- mkdir -p $(DESTDIR)$(datarootdir)/pacman
+- cp -fR Levels/ $(DESTDIR)$(datarootdir)/pacman/
+- -chown root:games $(DESTDIR)$(bindir)/pacman
+- -chown root:games $(DESTDIR)$(datarootdir)/pacman -R
+- chmod 750 $(DESTDIR)$(bindir)/pacman
+- chmod 750 $(DESTDIR)$(bindir)/pacmanedit
+- chmod 750 $(DESTDIR)$(datarootdir)/pacman/ -R
++ cp -f pacman4console pacman4consoleedit $(DESTDIR)$(bindir)/
++ mkdir -p $(DESTDIR)$(datarootdir)/pacman4console
++ cp -fR Levels/ $(DESTDIR)$(datarootdir)/pacman4console/
++ -chown root:games $(DESTDIR)$(bindir)/pacman4console
++ -chown root:games $(DESTDIR)$(datarootdir)/pacman4console -R
++ chmod 755 $(DESTDIR)$(bindir)/pacman4console
++ chmod 755 $(DESTDIR)$(bindir)/pacman4consoleedit
++ chmod 755 $(DESTDIR)$(datarootdir)/pacman4console -R
uninstall:
- rm -f /usr/local/bin/pacman
---- pacman.c 2009-12-22 13:28:23.423485413 +0100
-+++ pacman.c.new 2009-12-22 13:31:01.556844974 +0100
-@@ -196,10 +196,10 @@
-
- //Display ghosts
- if(Invincible == 0) {
-- wattron(win, COLOR_PAIR(Ghost1)); mvwaddch(win, Loc[0][0], Loc[0][1], '&');
-- wattron(win, COLOR_PAIR(Ghost2)); mvwaddch(win, Loc[1][0], Loc[1][1], '&');
-- wattron(win, COLOR_PAIR(Ghost3)); mvwaddch(win, Loc[2][0], Loc[2][1], '&');
-- wattron(win, COLOR_PAIR(Ghost4)); mvwaddch(win, Loc[3][0], Loc[3][1], '&');
-+ wattron(win, COLOR_PAIR(Ghost1)); mvwaddch(win, Loc[0][0], Loc[0][1], 'A');
-+ wattron(win, COLOR_PAIR(Ghost2)); mvwaddch(win, Loc[1][0], Loc[1][1], 'A');
-+ wattron(win, COLOR_PAIR(Ghost3)); mvwaddch(win, Loc[2][0], Loc[2][1], 'A');
-+ wattron(win, COLOR_PAIR(Ghost4)); mvwaddch(win, Loc[3][0], Loc[3][1], 'A');
- }
-
- //OR display vulnerable ghosts
-@@ -323,10 +323,10 @@
- if(getch()!=ERR) return;
- wattron(win, COLOR_PAIR(Pellet)); mvwprintw(win, 13, 23, "*");
- wattron(win, COLOR_PAIR(Pacman)); mvwprintw(win, 13, a, " C");
-- wattron(win, COLOR_PAIR(Ghost1)); mvwprintw(win, 13, a-3, " &");
-- wattron(win, COLOR_PAIR(Ghost3)); mvwprintw(win, 13, a-5, " &");
-- wattron(win, COLOR_PAIR(Ghost2)); mvwprintw(win, 13, a-7, " &");
-- wattron(win, COLOR_PAIR(Ghost4)); mvwprintw(win, 13, a-9, " &");
-+ wattron(win, COLOR_PAIR(Ghost1)); mvwprintw(win, 13, a-3, " A");
-+ wattron(win, COLOR_PAIR(Ghost3)); mvwprintw(win, 13, a-5, " A");
-+ wattron(win, COLOR_PAIR(Ghost2)); mvwprintw(win, 13, a-7, " A");
-+ wattron(win, COLOR_PAIR(Ghost4)); mvwprintw(win, 13, a-9, " A");
- wrefresh(win);
- usleep(100000);
- }
-@@ -341,7 +341,7 @@
- //Make ghosts half as fast
- if(a%2) b--;
-
-- wattron(win, COLOR_PAIR(BlueGhost)); mvwprintw(win, 13, b-9, "& & & &");
-+ wattron(win, COLOR_PAIR(BlueGhost)); mvwprintw(win, 13, b-9, "A A A A");
- wattron(win, COLOR_PAIR(Pacman)); mvwprintw(win, 13, b-9+1, " ");
- wattron(win, COLOR_PAIR(Pacman)); mvwprintw(win, 13, b-9+3, " ");
- wattron(win, COLOR_PAIR(Pacman)); mvwprintw(win, 13, b-9+5, " ");
---- pacman.h 2009-12-22 13:28:36.600151049 +0100
-+++ pacman.h.new 2009-12-22 13:31:14.193571255 +0100
-@@ -1,5 +1,5 @@
+ rm -f $(DESTDIR)$(bindir)/pacman
+
+--- pacman.h 2017-10-24 12:57:25.090817016 +0200
++++ pacman.h 2017-10-24 13:00:11.154040534 +0200
+@@ -1,7 +1,7 @@
// Some variables that you may want to change
--char LevelFile[50] = "/usr/local/share/pacman/Levels/level__.dat"; //Locations of default levels
-+char LevelFile[50] = "/usr/share/pacman4console/Levels/level__.dat"; //Locations of default levels
- int FreeLife = 1000; //Starting points for free life
- int Points = 0; //Initial points
- int Lives = 3; //Number of lives you start with
---- pacmanedit.c 2009-12-22 13:28:46.550158906 +0100
-+++ pacmanedit.c.new 2009-12-22 13:33:44.830134771 +0100
-@@ -89,10 +89,10 @@
- case 2: chr = '.'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Pellet)); break;
- case 3: chr = '*'; attr = A_BOLD; wattron(win, COLOR_PAIR(PowerUp)); break;
- case 4: chr = ' '; attr = A_NORMAL; wattron(win, COLOR_PAIR(GhostWall)); break;
-- case 5: chr = '&'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost1)); break;
-- case 6: chr = '&'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost2)); break;
-- case 7: chr = '&'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost3)); break;
-- case 8: chr = '&'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost4)); break;
-+ case 5: chr = 'A'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost1)); break;
-+ case 6: chr = 'A'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost2)); break;
-+ case 7: chr = 'A'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost3)); break;
-+ case 8: chr = 'A'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost4)); break;
- case 9: chr = 'C'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Pacman)); break;
- }
- mvwaddch(win, a, b, chr | attr);
-@@ -113,7 +113,7 @@
- wattron(status, COLOR_PAIR(Pellet)); mvwaddch(status, 1, 19, '.');
- wattron(status, COLOR_PAIR(PowerUp)); mvwaddch(status, 1, 26 , '*' | A_BOLD);
- wattron(status, COLOR_PAIR(GhostWall)); mvwaddch(status, 2, 3, ' ');
-- wattron(status, COLOR_PAIR(Ghost1)); mvwaddch(status, 2, 12, '&');
-+ wattron(status, COLOR_PAIR(Ghost1)); mvwaddch(status, 2, 12, 'A');
- wattron(status, COLOR_PAIR(Pacman)); mvwaddch(status, 2, 19, 'C');
- wrefresh(status);
+ #ifndef DATAROOTDIR
+-# define DATAROOTDIR "/usr/local/share"
++# define DATAROOTDIR "/usr/share/pacman4console"
+ #endif
+-#define LEVELS_FILE DATAROOTDIR "/pacman/Levels/level__.dat"
++#define LEVELS_FILE DATAROOTDIR "/pacman4console/Levels/level__.dat"
+ char LevelFile[] = LEVELS_FILE; //Locations of default levels
+
diff --git a/pacman4consoleedit b/pacman4consoleedit.1
index 33d95ad6be35..33d95ad6be35 100644
--- a/pacman4consoleedit
+++ b/pacman4consoleedit.1