summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cb102534890
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pact
+ pkgdesc = Interpreter for the Pact Smart Contract Language.
+ pkgver = 2.5.0
+ pkgrel = 1
+ url = http://kadena.io/pact
+ arch = x86_64
+ license = BSD 3-Clause
+ depends = gmp
+ depends = z3
+ source = https://kadena.io/pact/builds/2.5.0/ubuntu-1204/pact-2.5.0-linux.zip
+ md5sums = 32dd8cf6d509bf5204e4984feb9f1613
+
+pkgname = pact
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe7183d4d781
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Colin Woodbury <colin@kadena.io>
+
+pkgname=pact
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="Interpreter for the Pact Smart Contract Language."
+arch=('x86_64')
+url='http://kadena.io/pact'
+license=('BSD 3-Clause')
+depends=('gmp' 'z3')
+source=(https://kadena.io/pact/builds/${pkgver}/ubuntu-1204/pact-${pkgver}-linux.zip)
+md5sums=('32dd8cf6d509bf5204e4984feb9f1613')
+
+package() {
+ install -Dm 755 ${srcdir}/pact ${pkgdir}/usr/bin/pact
+}