summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD52
-rwxr-xr-xmakefile38
-rw-r--r--paintball-party-2.ChangeLog3
-rw-r--r--paintball-party-2.install0
-rw-r--r--pp2.desktop10
-rwxr-xr-xpp2.pngbin0 -> 1874 bytes
7 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e43765e7f8d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = paintball-party-2
+ pkgdesc = Paintball Party 2 is the sequel to Paintball Party, a multiplayer action platformer for all ages.
+ pkgver = 0.856
+ pkgrel = 1
+ url = http://www.t3-i.com/pages/download.php?id=8
+ install = paintball-party-2.install
+ changelog = paintball-party-2.ChangeLog
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = wget
+ makedepends = allegro
+ makedepends = mxml
+ options = emptydirs
+ source = paintball_party_2-0.856-linux.tar.gz::http://www.t3-i.com/pages/download.php?id=8
+ source = makefile
+ source = pp2.png
+ source = pp2.desktop
+ sha512sums = 44cf0528e95ddd7f13ca169c9870ed0a769245460d90bb3e216f3ad437d090b450bc904e8a9da1d43a26ec42d6081a8469570662d0ebb801277ed3896f715cd9
+ sha512sums = c05077e670f0cc6d0819259c9e4ada33fd8adb023824f4a923b5dce85d4ea6d8fc10ba3f0328d8092b485d73fb6081e5ff8e586353a80fe838e8decc2880abae
+ sha512sums = ebc6b1d5870808f3145bc63fb35b5ed04d7480791a91eeb2cbd7b43eade4932560cd7be7404f35e39e1d3c749def964a70c7e8498b6cc47590898d780042cff2
+ sha512sums = bc65833b64262e1f0c114eefe0e9bc6a4a0aa0cd0e00769ec9906776cd4e162b6bec4e90b90182c78f90d3a63aab169b64a36c151504e1e2b89c1fb4ebe2f8c0
+
+pkgname = paintball-party-2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6f1d641f8a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer Eray Aydın <eray at erayaydin dot me>
+
+pkgname=paintball-party-2
+pkgver=0.856
+_ver=0.856
+pkgrel=1
+pkgdesc="Paintball Party 2 is the sequel to Paintball Party, a multiplayer action platformer for all ages."
+arch=('i686' 'x86_64')
+url="http://www.t3-i.com/pages/download.php?id=8"
+_download="http://www.t3-i.com/pages/download.php?id=8"
+license=('custom')
+changelog=$pkgname.ChangeLog
+
+makedepends=('wget' 'allegro' 'mxml')
+install=$pkgname.install
+sha512sums=('44cf0528e95ddd7f13ca169c9870ed0a769245460d90bb3e216f3ad437d090b450bc904e8a9da1d43a26ec42d6081a8469570662d0ebb801277ed3896f715cd9'
+ 'c05077e670f0cc6d0819259c9e4ada33fd8adb023824f4a923b5dce85d4ea6d8fc10ba3f0328d8092b485d73fb6081e5ff8e586353a80fe838e8decc2880abae'
+ 'ebc6b1d5870808f3145bc63fb35b5ed04d7480791a91eeb2cbd7b43eade4932560cd7be7404f35e39e1d3c749def964a70c7e8498b6cc47590898d780042cff2'
+ 'bc65833b64262e1f0c114eefe0e9bc6a4a0aa0cd0e00769ec9906776cd4e162b6bec4e90b90182c78f90d3a63aab169b64a36c151504e1e2b89c1fb4ebe2f8c0')
+
+source=(paintball_party_2-${_ver}-linux.tar.gz::"${_download}"
+ "makefile"
+ "pp2.png"
+ "pp2.desktop")
+options=(emptydirs)
+
+build() {
+ tar -zxvf paintball_party_2-${_ver}-linux.tar.gz
+
+ mv makefile paintball_party_2-${_ver}/src/
+
+ cd paintball_party_2-${_ver}/src/
+
+ make
+}
+
+package() {
+
+ # create folders
+ install -d "$pkgdir"/{opt/paintball-party-2,usr/{share/{doc,licenses}/$pkgname,bin}}
+
+ # data
+ cp -R paintball_party_2-${_ver}/bin/data "$pkgdir"/opt/paintball-party-2
+
+ # executable
+ install -m755 paintball_party_2-${_ver}/bin/pp2 "$pkgdir"/opt/paintball-party-2
+ ln -s /opt/paintball-party-2/pp2 "$pkgdir"/usr/bin/paintball-party-2
+
+ # desktop launcher
+ install -Dm644 pp2.png "$pkgdir"/usr/share/pixmaps/pp2.png
+ install -Dm644 pp2.desktop "$pkgdir"/usr/share/applications/pp2.desktop
+} \ No newline at end of file
diff --git a/makefile b/makefile
new file mode 100755
index 000000000000..af43eb219728
--- /dev/null
+++ b/makefile
@@ -0,0 +1,38 @@
+CC = gcc
+CFLAGS = -O2 -fomit-frame-pointer -ffast-math -funroll-loops -Wall -Ijoynet/enet-1.2/include -DT3F_COMPANY="\"t3-i\"" -DT3F_PACKAGE_NAME="\"paintball-party-2\""
+RELEASE_LIBS = -lallegro_image -lallegro_font -lallegro_primitives -lallegro_audio -lallegro_acodec -lallegro_dialog -lallegro_memfile -lallegro -lcurl -lmxml -lm
+LIBS = $(RELEASE_LIBS)
+
+include makefile.common
+
+JOYNET_PLATFORM_OFILES = joynet/enet-1.2/unix.o
+PP2_EXENAME = ../bin/pp2
+LEVEDIT_EXENAME = ../bin/levedit
+CHAREDIT_EXENAME = ../bin/charedit
+
+all : $(PP2_EXENAME) $(LEVEDIT_EXENAME) $(CHAREDIT_EXENAME)
+
+$(PP2_EXENAME) : $(T3F_OFILES) $(JOYNET_OFILES) $(JOYNET_PLATFORM_OFILES) $(T3NET_OFILES) $(PP2_OFILES)
+ gcc $(T3F_OFILES) $(JOYNET_OFILES) $(JOYNET_PLATFORM_OFILES) $(T3NET_OFILES) $(PP2_OFILES) $(LIBS) -o $(PP2_EXENAME)
+
+$(LEVEDIT_EXENAME) : $(T3F_OFILES) $(LEVEDIT_OFILES)
+ gcc $(T3F_OFILES) $(LEVEDIT_OFILES) $(LIBS) -o $(LEVEDIT_EXENAME)
+
+$(CHAREDIT_EXENAME) : $(T3F_OFILES) $(CHAREDIT_OFILES)
+ gcc $(T3F_OFILES) $(CHAREDIT_OFILES) $(LIBS) -o $(CHAREDIT_EXENAME)
+
+clean:
+ @rm -f *.o
+ @rm -f file/*.o
+ @rm -f file/database/*.o
+ @rm -f legacy/*.o
+ @rm -f interface/*.o
+ @rm -f gameplay/*.o
+ @rm -f gameplay/sprites/*.o
+ @rm -f network/*.o
+ @rm -f misc/*.o
+ @rm -f t3f/*.o
+ @rm -f t3net/*.o
+ @rm -f joynet/*.o
+ @rm -f joynet/enet-1.2/*.o
+ @echo Cleanup complete!
diff --git a/paintball-party-2.ChangeLog b/paintball-party-2.ChangeLog
new file mode 100644
index 000000000000..ce5942a23abc
--- /dev/null
+++ b/paintball-party-2.ChangeLog
@@ -0,0 +1,3 @@
+2015-07-25 erayaydin <eray at erayaydin dot me>
+ * paintball-party-2 0.856 :
+ first initialize \ No newline at end of file
diff --git a/paintball-party-2.install b/paintball-party-2.install
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/paintball-party-2.install
diff --git a/pp2.desktop b/pp2.desktop
new file mode 100644
index 000000000000..b2540dd7dca1
--- /dev/null
+++ b/pp2.desktop
@@ -0,0 +1,10 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Type=Application
+Icon=pp2
+Exec=paintball-party-2
+Name=Paintball Party 2
+Comment=A multiplayer action platformer for all ages
+Categories=Game;ArcadeGame;
+Terminal=false
+StartupNotify=false
diff --git a/pp2.png b/pp2.png
new file mode 100755
index 000000000000..ffc6f23791f0
--- /dev/null
+++ b/pp2.png
Binary files differ