summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3dc4da8ca016..49750db89f57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pak-config-yay-git
pkgdesc = A yay config for pak
- pkgver = r3.f0ec020
+ pkgver = r20.dbd6a31
pkgrel = 1
url = https://gitlab.com/moussaelianarsen/pak
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = pak-config-yay-git
provides = pak-config
conflicts = pak-config-pacman-git
replaces = pak-config-yay
- source = https://gitlab.com/moussaelianarsen/pak/raw/master/plugins/yay/pak.cfg
+ source = git+https://gitlab.com/moussaelianarsen/pak.git
md5sums = SKIP
pkgname = pak-config-yay-git
diff --git a/PKGBUILD b/PKGBUILD
index d668c589e46a..ae3729bf2ebb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Arsen Musayelyan <moussaelianarsen@gmail.com>
pkgname=pak-config-yay-git
-pkgver=r3.f0ec020
+pkgver=r20.dbd6a31
pkgrel=1
pkgdesc="A yay config for pak"
arch=('x86_64')
@@ -9,10 +9,23 @@ license=('GPL3')
depends=('aptyay-git')
replaces=('pak-config-yay')
provides=('pak-config')
-source=("https://gitlab.com/moussaelianarsen/pak/raw/master/plugins/yay/pak.cfg")
+source=("git+https://gitlab.com/moussaelianarsen/pak.git")
md5sums=('SKIP')
conflicts=('pak-config-pacman-git')
+pkgver() {
+ cd "$srcdir/pak"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
package() {
- install -Dm644 pak.cfg $pkgdir/etc/pak.cfg
+ cd "$srcdir/pak"
+ install -Dm644 plugins/yay/pak.cfg $pkgdir/etc/pak.cfg
+ mkdir -p $pkgdir/etc/pak.d
+ install -Dm644 plugins/snap/pak.cfg $pkgdir/etc/pak.d/snap.cfg
+ install -Dm644 plugins/apy/pak.cfg $pkgdir/etc/pak.d/apt.cfg
+ install -Dm644 plugins/zypper/pak.cfg $pkgdir/etc/pak.d/zypper.cfg
+ install -Dm644 plugins/pacman/pak.cfg $pkgdir/etc/pak.d/pacman.cfg
+ install -Dm644 plugins/brew/pak.cfg $pkgdir/etc/pak.d/brew.cfg
+ install -Dm644 plugins/aptitude/pak.cfg $pkgdir/etc/pak.d/aptitude.cfg
}