summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--mozconfig.in21
-rw-r--r--mozconfig.in.patch24
4 files changed, 26 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 724edb223554..915deec71f22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = palemoon-26
- pkgdesc = Pale Moon web browser, old version 26 (still with the jetpack SDK addon technology, but not maintained anymore).
+ pkgdesc = Pale Moon web browser, old version 26 (still with the jetpack SDK addon technology, but not maintained anymore). Unofficial New Moon-branding.
pkgver = 26.5.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.palemoon.org/
arch = i686
arch = x86_64
@@ -28,13 +28,13 @@ pkgbase = palemoon-26
optdepends = gst-libav: h.264 support
optdepends = gst-plugins-good: h.264 support
provides = palemoon=26.5.0
+ provides = newmoon=26.5.0
conflicts = palemoon
+ conflicts = newmoon
source = git+https://github.com/MoonchildProductions/Pale-Moon#tag=26.5.0_Release
source = mozconfig.in
- source = mozconfig.in.patch
sha256sums = SKIP
- sha256sums = 6111b2df9057c770f83193b0ef3424ac45ce036951776f34f2bae45fe61d98bf
- sha256sums = c5ef03e89b49101748b5a255582ad8cf7c23a5dbf9d1d0dbd09302e806edeadb
+ sha256sums = 2f5b82b4257af9e7d77fbde1af406bf6cc9861fb3195161c2a9bba74c255e91b
pkgname = palemoon-26
diff --git a/PKGBUILD b/PKGBUILD
index f27db8f08692..e660e94a833b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
_pkgname=palemoon
pkgname="${_pkgname}-26"
pkgver=26.5.0
-pkgrel=1
-pkgdesc="Pale Moon web browser, old version 26 (still with the jetpack SDK addon technology, but not maintained anymore)."
+pkgrel=2
+pkgdesc="Pale Moon web browser, old version 26 (still with the jetpack SDK addon technology, but not maintained anymore). Unofficial New Moon-branding."
arch=(
'i686'
'x86_64'
@@ -16,9 +16,11 @@ arch=(
url="http://www.palemoon.org/"
provides=(
"${_pkgname}=${pkgver}"
+ "newmoon=${pkgver}"
)
conflicts=(
"${_pkgname}"
+ "newmoon"
)
license=(
'MPL'
@@ -53,18 +55,13 @@ optdepends=(
source=(
git+"https://github.com/MoonchildProductions/Pale-Moon#tag=${pkgver}_Release"
"mozconfig.in"
- "mozconfig.in.patch"
)
sha256sums=(
'SKIP'
- '6111b2df9057c770f83193b0ef3424ac45ce036951776f34f2bae45fe61d98bf'
- 'c5ef03e89b49101748b5a255582ad8cf7c23a5dbf9d1d0dbd09302e806edeadb'
+ '2f5b82b4257af9e7d77fbde1af406bf6cc9861fb3195161c2a9bba74c255e91b'
)
prepare() {
- msg "Patching 'mozconfig.in'"
- patch --verbose --follow-symlinks "${srcdir}/mozconfig.in" < "${srcdir}/mozconfig.in.patch"
-
sed 's#%SRCDIR%#'"$srcdir"'#g' mozconfig.in > mozconfig
cd Pale-Moon
diff --git a/mozconfig.in b/mozconfig.in
index 9b0837a8c6ed..52bd91ef0f08 100644
--- a/mozconfig.in
+++ b/mozconfig.in
@@ -1,4 +1,5 @@
-ac_add_options --enable-official-branding
+ac_add_options --disable-official-branding
+ac_add_options --with-branding=browser/branding/unofficial
export MOZILLA_OFFICIAL=1
mk_add_options MOZ_CO_PROJECT=browser
@@ -13,12 +14,12 @@ ac_add_options --disable-tests
ac_add_options --disable-mochitests
ac_add_options --disable-debug
-ac_add_options --enable-jemalloc
+ac_add_options --disable-jemalloc
#ac_add_options --enable-jemalloc-lib #does nothing?
ac_add_options --with-pthreads
ac_add_options --enable-strip
-ac_add_options --enable-optimize="-O2 -msse2 -mfpmath=sse"
+ac_add_options --enable-optimize="-O3 -msse2 -mfpmath=sse"
ac_add_options --x-libraries=/usr/lib
@@ -47,6 +48,16 @@ ac_add_options --disable-valgrind
# enable useful features
ac_add_options --enable-chrome-format=omni
ac_add_options --enable-gstreamer
-ac_add_options --enable-pulseaudio
-ac_add_options --enable-startup-notification
+ac_add_options --disable-pulseaudio
+ac_add_options --disable-startup-notification
+ac_add_options --enable-canvas
+ac_add_options --enable-svg
+ac_add_options --enable-accessibility
+ac_add_options --enable-xinerama
ac_add_options --enable-url-classifier
+
+# link to system libraries instead of internal ones
+#ac_add_options --with-system-zlib
+#ac_add_options --with-system-png
+#ac_add_options --with-system-jpeg
+#ac_add_options --enable-system-cairo
diff --git a/mozconfig.in.patch b/mozconfig.in.patch
deleted file mode 100644
index 177e831b1a9f..000000000000
--- a/mozconfig.in.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- mozconfig.in.orig 2016-11-13 10:28:07.030229334 +0100
-+++ mozconfig.in.new 2016-11-13 12:11:17.129308294 +0100
-@@ -16 +16 @@
--ac_add_options --enable-jemalloc
-+ac_add_options --disable-jemalloc
-@@ -21 +21 @@
--ac_add_options --enable-optimize="-O2 -msse2 -mfpmath=sse"
-+ac_add_options --enable-optimize="-O3 -msse2 -mfpmath=sse"
-@@ -50,2 +50,6 @@
--ac_add_options --enable-pulseaudio
--ac_add_options --enable-startup-notification
-+ac_add_options --disable-pulseaudio
-+ac_add_options --disable-startup-notification
-+ac_add_options --enable-canvas
-+ac_add_options --enable-svg
-+ac_add_options --enable-accessibility
-+ac_add_options --enable-xinerama
-@@ -52,0 +57,6 @@
-+
-+# link to system libraries instead of internal ones
-+#ac_add_options --with-system-zlib
-+#ac_add_options --with-system-png
-+#ac_add_options --with-system-jpeg
-+#ac_add_options --enable-system-cairo