summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abbb5f78d29e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pam-face-authentication
+ pkgdesc = PAM face auth
+ pkgver = 0.3
+ pkgrel = 7
+ url = http://code.google.com/p/pam-face-authentication
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = pam
+ depends = opencv
+ depends = libx11
+ depends = qt4
+ source = http://pam-face-authentication.googlecode.com/files/pam-face-authentication-0.3.tar.gz
+ md5sums = 5ef71bcf4bdebd2ee7216387ef17fc27
+
+pkgname = pam-face-authentication
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ac0cb6b606f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: M0Rf30
+# Contributor: Carlos RH Ruiz <ruizh.cj@gmail.com>
+
+pkgname=pam-face-authentication
+pkgver=0.3
+pkgrel=7
+pkgdesc="PAM face auth"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/pam-face-authentication"
+license=('GPL')
+depends=('pam' 'opencv' 'libx11' 'qt4')
+makedepends=('cmake')
+source=('http://pam-face-authentication.googlecode.com/files/pam-face-authentication-0.3.tar.gz')
+
+build() {
+cd "$srcdir"/${pkgname}-$pkgver
+
+ rm cmake/modules/FindOpenCV.cmake
+ cp /usr/share/opencv/OpenCVConfig.cmake cmake/modules
+ sed -i 's/OPENCV_LIBRARIES/OpenCV_LIBS/g' CMakeLists.txt
+ cmake -D CMAKE_INSTALL_PREFIX=/usr -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4 .
+}
+
+package() {
+cd ${srcdir}/${pkgname}-$pkgver
+make || return 1
+make DESTDIR="$pkgdir/" install || return 1
+}
+
+md5sums=('5ef71bcf4bdebd2ee7216387ef17fc27')