summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dabfde7ee0e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pam_encfs
+ pkgdesc = pam_encfs is a module to auto mount encfs dir on login
+ pkgver = 0.1.4.4
+ pkgrel = 2
+ url = http://code.google.com/p/pam-encfs/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = encfs
+ backup = etc/security/pam_encfs.conf
+ source = http://pam-encfs.googlecode.com/files/pam_encfs-0.1.4.4.tar.gz
+ md5sums = 20d10fa842e968a224af542db7e10d21
+
+pkgname = pam_encfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a012fd7c111b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Guillem Rieu <guillemr@gmx.net>
+
+pkgname=pam_encfs
+pkgver=0.1.4.4
+pkgrel=2
+pkgdesc="pam_encfs is a module to auto mount encfs dir on login"
+url="http://code.google.com/p/pam-encfs/"
+arch=(i686 x86_64)
+depends=('encfs')
+backup=('etc/security/pam_encfs.conf')
+license="GPL"
+source=(http://pam-encfs.googlecode.com/files/$pkgname-$pkgver.tar.gz)
+md5sums=('20d10fa842e968a224af542db7e10d21')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make || return 1
+ make DESTDIR=${pkgdir}/usr install || return 1
+ mkdir -p $pkgdir/etc/security
+ cp pam_encfs.conf $pkgdir/etc/security
+}