summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 091f32fb5566..c08d65273b3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pamac-aur-git
pkgdesc = A Gtk3 frontend for libalpm - git version
pkgver = v6.2.6.r1.g2370068
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/manjaro/pamac
arch = i686
arch = x86_64
@@ -33,6 +33,7 @@ pkgbase = pamac-aur-git
pkgname = pamac-aur-git
install = pamac.install
+ conflicts = pamac-aur
replaces = pamac-aur
backup = etc/pamac.conf
@@ -40,4 +41,6 @@ pkgname = pamac-aur-tray-appindicator-git
pkgdesc = Tray icon using appindicator which feets better in KDE - git version
depends = pamac-aur-git
depends = libappindicator-gtk3
+ conflicts = pamac-aur-tray-indicator
+ replaces = pamac-aur-tray-indicator
diff --git a/PKGBUILD b/PKGBUILD
index 9af0cb436f5b..67b18e43580c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=('pamac-aur-git' 'pamac-aur-tray-appindicator-git')
_pkgname=pamac
pkgver=v6.2.6.r1.g2370068
_pkgver=6.2.3
-pkgrel=1
+pkgrel=2
pkgdesc="A Gtk3 frontend for libalpm - git version"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/manjaro/pamac"
@@ -45,6 +45,7 @@ build() {
package_pamac-aur-git() {
backup=('etc/pamac.conf')
+ conflicts=('pamac-aur')
replaces=('pamac-aur')
install=pamac.install
cd "$_pkgname"
@@ -61,6 +62,8 @@ package_pamac-aur-git() {
package_pamac-aur-tray-appindicator-git() {
pkgdesc="Tray icon using appindicator which feets better in KDE - git version"
+ conflicts=('pamac-aur-tray-indicator')
+ replaces=('pamac-aur-tray-indicator')
depends=('pamac-aur-git' 'libappindicator-gtk3')
cd "$_pkgname"
install -Dm755 "builddir/src/pamac-tray-appindicator" "$pkgdir/usr/bin/pamac-tray-appindicator"