summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD36
2 files changed, 9 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86c856ddb2c6..1893ef75332f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,40 +1,17 @@
pkgbase = pantheon-qq-common
pkgdesc = Common dependencies of Pantheon 3D and Pantheon Lite
- pkgver = 1
- pkgrel = 2
+ pkgver = 2
+ pkgrel = 1
url = https://github.com/quequotion/pantheon-qq
arch = any
groups = pantheon-qq
license = GPL3
- depends = cinnamon-settings-daemon
- depends = pantheon-settings-daemon
- depends = gnome-keyring
- depends = gnome-session
- depends = xdg-user-dirs-gtk
- depends = wingpanel
- depends = pantheon-dock
- depends = pantheon-applications-menu
- optdepends = contractor: A desktop-wide extension service
- optdepends = dconf-editor: GUI gsettings editor
+ depends = pantheon-session
optdepends = elementary-blue-icon-theme-git: Restore blue folder icons to elementary theme
optdepends = file-roller-pantheon: Archive manipulator for GNOME (with elementary OS patches)
optdepends = lightdm-gtk-greeter: GTK+ Greeter for LightDM
optdepends = numlockx: Turn on the numlock key in X11
- optdepends = pantheon-calculator: The Pantheon Calculator
- optdepends = pantheon-calendar: The Pantheon Calendar
- optdepends = pantheon-code: The Pantheon Code Editor
- optdepends = pantheon-default-settings: Default settings for Pantheon
- optdepends = pantheon-dock-instctl-git: Dock for Pantheon with instance controls
- optdepends = pantheon-dpms-helper: DPMS helper for Pantheon
- optdepends = pantheon-files: The Pantheon File Browser
- optdepends = pantheon-geoclue2-agent: Pantheon Geoclue2 Agent
- optdepends = pantheon-music: The Pantheon Music Player
- optdepends = pantheon-notifications: A Gtk notification server for Pantheon
- optdepends = pantheon-photos: The Pantheon Photos Manager
- optdepends = pantheon-polkit-agent: Pantheon Polkit Agent
- optdepends = pantheon-print: Simple shim for printing support via Contractor
- optdepends = pantheon-screenshot: The Pantheon Screenshot Tool
- optdepends = pantheon-terminal: The Pantheon Terminal Emulator
+ optdepends = pantheon-dock-instctl-git: Dock for Pantheon (with instance controls)
optdepends = xscreensaver-dbus-screenlock: xscreensaver locker for gnome-derivative desktops
optdepends = wingpanel-standalone-git: Stylish top panel (with autohide and without Gala dependencies)
conflicts = pantheon-workarounds
diff --git a/PKGBUILD b/PKGBUILD
index 36564ead4cca..6a2c51d70eed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,36 +3,19 @@
# Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
pkgname=pantheon-qq-common
-pkgver=1
-pkgrel=2
+pkgver=2
+pkgrel=1
pkgdesc='Common dependencies of Pantheon 3D and Pantheon Lite'
arch=('any')
url='https://github.com/quequotion/pantheon-qq'
license=('GPL3')
groups=('pantheon-qq')
-depends=({cinnamon,pantheon}-settings-daemon gnome-{keyring,session} 'xdg-user-dirs-gtk'
- wingpanel pantheon-{dock,applications-menu})
-optdepends=("contractor: A desktop-wide extension service"
- "dconf-editor: GUI gsettings editor"
- "elementary-blue-icon-theme-git: Restore blue folder icons to elementary theme"
+depends=(pantheon-session)
+optdepends=("elementary-blue-icon-theme-git: Restore blue folder icons to elementary theme"
"file-roller-pantheon: Archive manipulator for GNOME (with elementary OS patches)"
"lightdm-gtk-greeter: GTK+ Greeter for LightDM"
"numlockx: Turn on the numlock key in X11"
- "pantheon-calculator: The Pantheon Calculator"
- "pantheon-calendar: The Pantheon Calendar"
- "pantheon-code: The Pantheon Code Editor"
- "pantheon-default-settings: Default settings for Pantheon"
- "pantheon-dock-instctl-git: Dock for Pantheon with instance controls"
- "pantheon-dpms-helper: DPMS helper for Pantheon"
- "pantheon-files: The Pantheon File Browser"
- "pantheon-geoclue2-agent: Pantheon Geoclue2 Agent"
- "pantheon-music: The Pantheon Music Player"
- "pantheon-notifications: A Gtk notification server for Pantheon"
- "pantheon-photos: The Pantheon Photos Manager"
- "pantheon-polkit-agent: Pantheon Polkit Agent"
- "pantheon-print: Simple shim for printing support via Contractor"
- "pantheon-screenshot: The Pantheon Screenshot Tool"
- "pantheon-terminal: The Pantheon Terminal Emulator"
+ "pantheon-dock-instctl-git: Dock for Pantheon (with instance controls)"
"xscreensaver-dbus-screenlock: xscreensaver locker for gnome-derivative desktops"
"wingpanel-standalone-git: Stylish top panel (with autohide and without Gala dependencies)")
conflicts=('pantheon-workarounds')
@@ -48,14 +31,5 @@ package() {
#Script to initiate Pantheon derivative gnome-sessions
install -Dm755 {"${srcdir}","${pkgdir}"/usr/bin}/pantheon-session-qq
- #Use cinnamon-settings-daemon (gnome-settings-daemon has deprecated modularity and xorg)
- #Skip "Screensaver" plugin in Pantheon: session-indicator needs org.gnome.ScreenSaver.Lock
- #Skip "Xrandr" plugin in Pantheon: monitors.xml configuration doesn't seem to work, is undocumented, etc.
- for i in /etc/xdg/autostart/cinnamon-settings-daemon-*.desktop; do
- if [[ ${i} != *screensaver* ]] && [[ ${i} != *xrandr* ]] && [[ ${i} != *pantheon* ]]; then
- sed s/X-Cinnamon/Pantheon/ "${i}" > "${pkgdir}${i/.desktop/-pantheon.desktop}"
- fi
- done
-
echo "Get the latest dotfiles: https://gist.github.com/quequotion/a7c2e82451a87a05dbca50e5e8176615"
}