summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1636e90ee6f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = paper-icon-theme-git
+ pkgdesc = Paper is an icon theme for GTK based desktops and fits perfectly the paper-gtk-theme
+ pkgver = 0.r2.aca8802
+ pkgrel = 1
+ url = https://github.com/snwh/paper-icon-theme
+ arch = i686
+ arch = x86_64
+ license = CC BY-SA 4.0
+ makedepends = git
+ depends = librsvg
+ provides = paper-icon-theme
+ source = paper-icon-theme-git::git+https://github.com/snwh/paper-icon-theme.git
+ md5sums = SKIP
+
+pkgname = paper-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f55fb0f6c395
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=paper-icon-theme-git
+pkgver=0.r2.aca8802
+pkgrel=1
+pkgdesc="Paper is an icon theme for GTK based desktops and fits perfectly the paper-gtk-theme"
+arch=('i686' 'x86_64')
+url="https://github.com/snwh/paper-icon-theme"
+license=('CC BY-SA 4.0')
+depends=('librsvg')
+makedepends=('git')
+provides=('paper-icon-theme')
+source=("$pkgname"::'git+https://github.com/snwh/paper-icon-theme.git')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # Use the tag of the last commit
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname/Paper"
+ install -d -m 755 "$pkgdir"/usr/share/icons/Paper
+ rm -rf {.git,.gitignore,CONTRIBUTORS,COPYING,CREDITS,LICENSE.txt,README.md}
+ cp -r . "$pkgdir"/usr/share/icons/Paper/
+}