summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
-rw-r--r--configure.ac.patch19
3 files changed, 14 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1043d2030170..2de2c45574b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Oct 18 09:12:37 UTC 2017
+# Sun Jun 17 12:45:45 UTC 2018
pkgbase = paper-icon-theme-git
pkgdesc = Paper is an icon theme for GTK based desktops and fits perfectly the paper-gtk-theme
- pkgver = 749.c153195c
+ pkgver = 800.7860fba8
pkgrel = 1
url = https://github.com/snwh/paper-icon-theme
arch = any
@@ -12,9 +12,7 @@ pkgbase = paper-icon-theme-git
depends = gtk-update-icon-cache
provides = paper-icon-theme
source = paper-icon-theme-git::git+https://github.com/snwh/paper-icon-theme.git
- source = configure.ac.patch
md5sums = SKIP
- md5sums = 1aeca8418ee2f609ca5d86557ffcad89
pkgname = paper-icon-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index b628a6fe945b..b8561422b377 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=paper-icon-theme-git
-pkgver=749.c153195c
+pkgver=800.7860fba8
pkgrel=1
pkgdesc="Paper is an icon theme for GTK based desktops and fits perfectly the paper-gtk-theme"
arch=(any)
@@ -8,26 +8,26 @@ license=('CC BY-SA 4.0')
depends=('gtk-update-icon-cache')
makedepends=('git' 'automake')
provides=('paper-icon-theme')
-source=("$pkgname"::'git+https://github.com/snwh/paper-icon-theme.git'
- "configure.ac.patch")
+source=("$pkgname"::'git+https://github.com/snwh/paper-icon-theme.git')
# Because the sources are not static, skip Git checksum:
-md5sums=('SKIP'
- '1aeca8418ee2f609ca5d86557ffcad89')
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
+prepare() {
+ cd "${pkgname}"
+ meson build --prefix=/usr
+}
+
build() {
- cd $srcdir/$pkgname
- patch configure.ac $srcdir/configure.ac.patch
- ./autogen.sh --prefix=/usr
- make
+ cd "${pkgname}/build"
+ ninja
}
package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir" install
- rm -f "${pkgdir}/usr/share/icons/gnome/icon-theme.cache"
+ cd "${pkgname}/build"
+ DESTDIR="$pkgdir" ninja install
}
diff --git a/configure.ac.patch b/configure.ac.patch
deleted file mode 100644
index 766fce14fe22..000000000000
--- a/configure.ac.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- configure.ac 2016-05-27 18:15:33.000000000 +0200
-+++ configure.ac.new 2016-05-28 11:17:11.622530477 +0200
-@@ -1,8 +1,7 @@
- AC_INIT([Paper ], 1.1, [https://github.com/snwh/paper-icon-theme/issues], [paper-icon-theme], [http://snwh.org/paper])
- AM_INIT_AUTOMAKE([-Wno-portability no-dist-gzip dist-xz foreign subdir-objects 1.9 tar-ustar])
- AC_PREFIX_DEFAULT(/usr/local)
--AM_SILENT_RULES([yes])
--
-+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
-
- AC_CONFIG_FILES([Makefile])
- AC_OUTPUT
-@@ -15,4 +14,4 @@
- exec_prefix: ${exec_prefix}
- datarootdir: ${datarootdir}
-
--])
-\ No newline at end of file
-+])