summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
-rw-r--r--paperless.conf28
-rw-r--r--paperless.install17
4 files changed, 55 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4930942f77f..10b4937aaf7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = paperless
pkgdesc = Scan, index, and archive all of your paper documents
- pkgver = 2.6.0
+ pkgver = 2.7.0
pkgrel = 1
url = https://github.com/danielquinn/paperless
install = paperless.install
arch = any
license = GPL3
+ depends = imagemagick
+ depends = python-ply
depends = python-django>=2.0.9
depends = python-django-extensions>=2.1.3
depends = python-django-rest-framework>=3.7.7
@@ -30,15 +32,16 @@ pkgbase = paperless
depends = python-regex>=2018.11.2
depends = python-django-cors-headers>=2.4.0
depends = python-termcolor>=1.1.0
+ depends = python-djangoql
depends = optipng
options = !buildflags
backup = etc/paperless.conf
- source = paperless-2.6.0.tar.gz::https://github.com/danielquinn/paperless/archive/2.6.0.tar.gz
+ source = paperless-2.7.0.tar.gz::https://github.com/danielquinn/paperless/archive/2.7.0.tar.gz
source = paperless.conf
source = paperless-consumer.service
source = paperless-webserver.service
- sha512sums = 733cb67a7af6d09eec18fb3246b35c6010cb84fc0571b25c3f4236386a604d97ec5b8278f9929e1b28bdd64dd38a696c27462eb0bbe36121662cd47b417d9d19
- sha512sums = 3b57ccd9515b23847dc366fb8183ec4c1fd1c27a5186d5ed5f0a4c7d5d1be1e2adac625d7525b1a710727fcd2b8e8693305997ce6b8b6b683fa4dfa0fdc1a20a
+ sha512sums = 415dd86c4fcd561f25815498d4d05fb3d96d4fa58876cb8189a2cd5bef5ea150c494dc002e52479de641d3c87c0ef52a9a8c545bb8fb41ffad1d2aec350039c7
+ sha512sums = 5f5f208bb1613d24a422fae400be9c2e1798a7aba5595fd985abbfc55c84809cbc47625203d49dd15aa8f6cb5ab85282223bd29ba76c8c819698d60549c94287
sha512sums = de3a825b24e310d6d97446cb7d206718eba10d6ab4c63c140a0325fe5e641d422bfdf0e39dc10406c37157ff6d2a45764a4d9c4f1559555e0023aef467d6f137
sha512sums = c148bffd5b7cde4730043955921f9220251abf330c54f20169863edd2acf5d5a59b2c59cdf50fb3e4a09587e813a54ef334c0c96ea55c3b8e419ea032c42ccf3
diff --git a/PKGBUILD b/PKGBUILD
index 8ae3ff5bae9d..b35f48e61790 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Wolfgang Mader <Wolfgang at Mad3r dot de>
pkgname=paperless
-pkgver=2.6.0
+pkgver=2.7.0
pkgrel=1
pkgdesc="Scan, index, and archive all of your paper documents"
arch=('any')
url="https://github.com/danielquinn/paperless"
license=('GPL3')
options=(!buildflags)
-depends=('python-django>=2.0.9' 'python-django-extensions>=2.1.3' 'python-django-rest-framework>=3.7.7' 'python-django-crispy-forms>=1.7.2' 'python-django-filter>=2.0.0' 'python-fuzzywuzzy>=0.16.0' 'python-pyocr>=0.5.3' 'python-gnupg>=0.4.3' 'python-pillow>=5.3' 'python-dotenv>=0.9.1' 'python-dateutil>=2.7.5' 'python-magic' 'python-langdetect>=1.0.7' 'tesseract' 'unpaper' 'ghostscript' 'python-dateparser>=0.7.0' 'python-pdftotext>=2.1.1' 'python-more-itertools>=4.3.0' 'python-levenshtein>=0.12' 'python-pytz>=2018.7' 'python-regex>=2018.11.2' 'python-django-cors-headers>=2.4.0' 'python-termcolor>=1.1.0' 'optipng')
+depends=('imagemagick' 'python-ply' 'python-django>=2.0.9' 'python-django-extensions>=2.1.3' 'python-django-rest-framework>=3.7.7' 'python-django-crispy-forms>=1.7.2' 'python-django-filter>=2.0.0' 'python-fuzzywuzzy>=0.16.0' 'python-pyocr>=0.5.3' 'python-gnupg>=0.4.3' 'python-pillow>=5.3' 'python-dotenv>=0.9.1' 'python-dateutil>=2.7.5' 'python-magic' 'python-langdetect>=1.0.7' 'tesseract' 'unpaper' 'ghostscript' 'python-dateparser>=0.7.0' 'python-pdftotext>=2.1.1' 'python-more-itertools>=4.3.0' 'python-levenshtein>=0.12' 'python-pytz>=2018.7' 'python-regex>=2018.11.2' 'python-django-cors-headers>=2.4.0' 'python-termcolor>=1.1.0' 'python-djangoql' 'optipng')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
paperless.conf
paperless-consumer.service
paperless-webserver.service)
-sha512sums=('733cb67a7af6d09eec18fb3246b35c6010cb84fc0571b25c3f4236386a604d97ec5b8278f9929e1b28bdd64dd38a696c27462eb0bbe36121662cd47b417d9d19'
- '3b57ccd9515b23847dc366fb8183ec4c1fd1c27a5186d5ed5f0a4c7d5d1be1e2adac625d7525b1a710727fcd2b8e8693305997ce6b8b6b683fa4dfa0fdc1a20a'
+sha512sums=('415dd86c4fcd561f25815498d4d05fb3d96d4fa58876cb8189a2cd5bef5ea150c494dc002e52479de641d3c87c0ef52a9a8c545bb8fb41ffad1d2aec350039c7'
+ '5f5f208bb1613d24a422fae400be9c2e1798a7aba5595fd985abbfc55c84809cbc47625203d49dd15aa8f6cb5ab85282223bd29ba76c8c819698d60549c94287'
'de3a825b24e310d6d97446cb7d206718eba10d6ab4c63c140a0325fe5e641d422bfdf0e39dc10406c37157ff6d2a45764a4d9c4f1559555e0023aef467d6f137'
'c148bffd5b7cde4730043955921f9220251abf330c54f20169863edd2acf5d5a59b2c59cdf50fb3e4a09587e813a54ef334c0c96ea55c3b8e419ea032c42ccf3')
backup=("etc/paperless.conf")
diff --git a/paperless.conf b/paperless.conf
index 58d3f09d9061..24fa6c94706e 100644
--- a/paperless.conf
+++ b/paperless.conf
@@ -2,6 +2,27 @@
# Copy this file to /etc/paperless.conf and modify it to suit your needs.
# As this file contains passwords it should only be readable by the user
# running paperless.
+# Set at least the values for
+# PAPERLESS_CONSUMPTION_DIR: this is where your documents will be dumped
+# to be consumed by Paperless.
+#
+# PAPERLESS_OCR_THREADS: this is the number of threads the OCR process
+# will spawn to process document pages in parallel.
+#
+# PAPERLESS_OCR_LANGUAGE: Default to eng. Change it to the default language
+# of your documents and install the respective
+# OCR language pack.
+#
+# PAPERLESS_PASSPHRASE: this is only required if you want to use GPG to
+# encrypt your document files. This is the passphrase
+# Paperless uses to encrypt/decrypt the original documents.
+# Don’t worry about defining this if you don’t want to use
+# encryption (the default).
+#
+# If you want to run the default django-webserver comming with paperless on a
+# public network, also set
+# PAPERLESS_ALLOWED_HOSTS
+
###############################################################################
@@ -61,7 +82,7 @@ PAPERLESS_EMAIL_SECRET=""
# Controls whether django's debug mode is enabled. Disable this on production
# systems. Debug mode is enabled by default.
-PAPERLESS_DEBUG="false"
+#PAPERLESS_DEBUG="true"
# Paperless can be instructed to attempt to encrypt your PDF files with GPG
@@ -202,6 +223,11 @@ PAPERLESS_DEBUG="false"
#PAPERLESS_FORGIVING_OCR="false"
+# By default Paperless does not OCR a document if the text can be retrieved from
+# the document directly. Set to true to always OCR documents.
+#PAPERLESS_OCR_ALWAYS="false"
+
+
###############################################################################
#### Interface ####
###############################################################################
diff --git a/paperless.install b/paperless.install
index f5bcbcb96d94..33d607729b49 100644
--- a/paperless.install
+++ b/paperless.install
@@ -11,6 +11,14 @@ post_install() {
echo "Start/enable paperless webserver and file consumer"
echo " systemctl start paperless-webserver.service"
echo " systemctl start paperless-consumer.service"
+ echo
+ echo "CAVE: imagemagic's convert does not work on pdf files."
+ echo " There is a security risc accociated with convert acting on e.g. pdf files"
+ echo " https://bugs.archlinux.org/task/59778"
+ echo " You can enable convert for pdf files or other files by following the description here"
+ echo " https://bugs.archlinux.org/task/60580"
+ echo " In case you decide not to enable convert for pdf files, consumption of files in"
+ echo " paperless degrades"
}
post_upgrade() {
@@ -26,4 +34,13 @@ post_upgrade() {
echo " through your entire database and Decrypt All The Things."
echo " 2: Remove PAPERLESS_PASSPHRASE from your paperless.conf file, or simply stop declaring it in"
echo " your environment."
+
+ echo
+ echo "CAVE: imagemagic's convert does not work on pdf files."
+ echo " There is a security risc accociated with convert acting on e.g. pdf files"
+ echo " https://bugs.archlinux.org/task/59778"
+ echo " You can enable convert for pdf files or other files by following the description here"
+ echo " https://bugs.archlinux.org/task/60580"
+ echo " In case you decide not to enable convert for pdf files, consumption of files in"
+ echo " paperless degrades"
}