summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD27
2 files changed, 20 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe31c8847243..2b5fbdd93c87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = papermerge
pkgdesc = An open source document management system (DMS) primarily designed for archiving and retrieving your digital documents.
pkgver = 1.5.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ciur/papermerge
install = papermerge.install
arch = any
license = Apache
+ makedepends = python-setuptools
depends = imagemagick
depends = pdftk
depends = poppler
@@ -49,4 +50,3 @@ pkgbase = papermerge
sha512sums = b838d54dca56e45f99690ddaae1b058e3f72b314adf9d689869f14bb141a5bbf209df974eea20cb2305b127d5119d0b8d11293494d47350f6974edc6fffc374f
pkgname = papermerge
-
diff --git a/PKGBUILD b/PKGBUILD
index f4b47fae269f..e3eb7572b4a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,26 @@
-# Maintainer: amo <https://aur.archlinux.org/account/amo>
+# Contributor: amo <https://aur.archlinux.org/account/amo>
# Contributor: Lucki <https://aur.archlinux.org/account/Lucki>
pkgname=papermerge
pkgver=1.5.5
-pkgrel=1
+pkgrel=2
pkgdesc="An open source document management system (DMS) primarily designed for archiving and retrieving your digital documents."
arch=('any')
url="https://github.com/ciur/papermerge"
license=('Apache')
backup=("etc/$pkgname.conf.py" "usr/lib/python3.9/site-packages/config/settings/production.py")
install=$pkgname.install
-depends=('imagemagick' 'pdftk' 'poppler' 'python-celery' 'python-django' 'python-django-allauth' 'python-django-celery-results' 'python-django-dynamic-preferences' 'python-django-modelcluster' 'python-django-mptt' 'python-django-polymorphic-tree' 'python-django-rest-framework' 'python-django-rest-knox' 'python-django-taggit' 'python-imapclient' 'python-lxml' 'python-mgclipboard' 'python-mglib' 'python-psycopg2' 'python-pyaml' 'tesseract' 'gunicorn')
-optdepends=('nginx: reverse proxy for papermerge provided by gunicorn' 'redis: file based transport of messaging queue' 'python-redis: file based transport of messaging queue')
+depends=('imagemagick' 'pdftk' 'poppler' 'python-celery'
+ 'python-django' 'python-django-allauth' 'python-django-celery-results'
+ 'python-django-dynamic-preferences' 'python-django-modelcluster'
+ 'python-django-mptt' 'python-django-polymorphic-tree' 'python-django-rest-framework'
+ 'python-django-rest-knox' 'python-django-taggit' 'python-imapclient' 'python-lxml'
+ 'python-mgclipboard' 'python-mglib' 'python-psycopg2' 'python-pyaml' 'tesseract' 'gunicorn')
+makedepends=('python-setuptools')
+#checkdepends=('python-dateutil')
+optdepends=('nginx: reverse proxy for papermerge provided by gunicorn'
+ 'redis: file based transport of messaging queue'
+ 'python-redis: file based transport of messaging queue')
source=("$pkgname-$pkgver.src.tar.gz::https://github.com/ciur/$pkgname/archive/v$pkgver.tar.gz"
"$pkgname.install"
"$pkgname.sysusers"
@@ -49,14 +58,14 @@ prepare() {
}
build() {
- cd "$pkgname-$pkgver" || exit
+ cd "$pkgname-$pkgver"
python setup.py build
}
-check() {
- cd "$pkgname-$pkgver" || exit
- ./run_tests.sh
-}
+#check() {
+# cd "$pkgname-$pkgver"
+# ./run_tests.sh
+#}
package() {
# tmpfiles.d