summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b8fee2eaee2..2040b1ae8fa7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,20 @@
pkgbase = papi-cuda
pkgdesc = Performance Application Programming Interface (with CUDA componet)
- pkgver = 6.0.0
+ pkgver = 7.0.0
pkgrel = 1
url = http://icl.cs.utk.edu/papi/
arch = x86_64
- arch = i686
license = BSD
- depends = python
+ depends = python-argparse
depends = gcc-fortran
depends = cuda
optdepends = openmpi: for MPI applications
- provides = papi=6.0.0
+ provides = papi=7.0.0
conflicts = papi
conflicts = libpfm4
- source = http://icl.cs.utk.edu/projects/papi/downloads/papi-6.0.0.tar.gz
+ source = http://icl.cs.utk.edu/projects/papi/downloads/papi-7.0.0.tar.gz
source = cuda-component-build-targets.patch
- sha256sums = 3442709dae3405c2845b304c06a8b15395ecf4f3899a89ceb4d715103cb4055f
+ sha256sums = 799dcc317a47da96beaeed445812ecb6ae49df7c0504a4569797c1f7d74c4fd2
sha256sums = 0b93df095425fd5d5a9166bb4d62a71a9ab62708b9364cb9da4193d2b60a890f
pkgname = papi-cuda
-
diff --git a/PKGBUILD b/PKGBUILD
index b4c6af292176..76c3b687a91a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
# Contributor: jedbrown
pkgname=papi-cuda
-pkgver=6.0.0
+pkgver=7.0.0
pkgrel=1
pkgdesc='Performance Application Programming Interface (with CUDA componet)'
-arch=('x86_64' 'i686')
+arch=('x86_64')
url='http://icl.cs.utk.edu/papi/'
license=('BSD')
provides=("papi=${pkgver}")
conflicts=('papi' 'libpfm4')
-depends=('python' 'gcc-fortran' 'cuda')
+depends=('python-argparse' 'gcc-fortran' 'cuda')
optdepends=('openmpi: for MPI applications')
source=("http://icl.cs.utk.edu/projects/papi/downloads/papi-${pkgver}.tar.gz"
'cuda-component-build-targets.patch')
-sha256sums=('3442709dae3405c2845b304c06a8b15395ecf4f3899a89ceb4d715103cb4055f'
+sha256sums=('799dcc317a47da96beaeed445812ecb6ae49df7c0504a4569797c1f7d74c4fd2'
'0b93df095425fd5d5a9166bb4d62a71a9ab62708b9364cb9da4193d2b60a890f')
prepare() {
@@ -28,11 +28,16 @@ prepare() {
build() {
cd "${srcdir}/papi-${pkgver}/src"
- export CFLAGS="-fPIC ${CFLAGS}"
+ # FIXME for the cuda component there are a few snprintf calls which
+ # trigger the format-security checks. I might try to write a
+ # patch for this, but for now we disable this check locally.
+ export CFLAGS="-fPIC ${CFLAGS/-Werror=format-security/}"
+ export CXXFLAGS=${CXXFLAGS/-Werror=format-security/}
export CC=gcc # for systems with other CC installed
export F77=gfortran # for systems with other FC installed
export CUDA_DIR=/opt/cuda
export CUPTI_DIR=/opt/cuda/extras/CUPTI
+
./configure \
--prefix=/usr \
--with-static-lib=yes --with-shared-lib=yes \