summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD66
-rw-r--r--papyrus3
-rw-r--r--papyrus.desktop11
-rw-r--r--papyrus.pngbin0 -> 25059 bytes
6 files changed, 72 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7a7ef3cf2eb..03b791b40845 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
-# Generated by mksrcinfo v8
-# Sun Jan 29 14:14:35 UTC 2017
pkgbase = papyrus
pkgdesc = Graphical editing tool for UML based on eclipse.
- pkgver = 2.0.2
+ pkgver = 6.6.0
pkgrel = 1
url = http://www.eclipse.org/papyrus/
- arch = i686
arch = x86_64
license = EPL
makedepends = tar
- depends = java-runtime
- source_i686 = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/modeling/mdt/papyrus/rcp/neon/2.0.2/papyrus-neon-2.0.2-linux32.tar.gz
- md5sums_i686 = 55ab4ea4cc6da06fbdea4e2659f49498
- source_x86_64 = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/modeling/mdt/papyrus/rcp/neon/2.0.2/papyrus-neon-2.0.2-linux64.tar.gz
- md5sums_x86_64 = 6304576c21d5560f9dd1d112e7c4364b
+ depends = python
+ depends = perl
+ depends = bash
+ provides = papyrus
+ conflicts = papyrus
+ source = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/modeling/mdt/papyrus/rcp/2023-12/6.6.0/papyrus-2023-12-6.6.0-linux64.tar.gz
+ source = papyrus.png
+ source = papyrus.desktop
+ source = papyrus
+ sha256sums = f5c3509e67f852214df53f9672b37bae6deb51df16ebb44da4038e25ca16a5d8
+ sha256sums = 0bf0ff5eacc3e955a01c171cc21d8c989707ed9eee668ce176d67cfae06c8608
+ sha256sums = 255f1d8b0277bb9e4a3f84d09294fe34a54485b29f67220733343f37db052b94
+ sha256sums = 45387c39208b4e18f70059059729dfd06ed4c3393065aebd299072c6eec888ea
pkgname = papyrus
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0c935002060d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+
+!PKGBUILD
+!.SRCINFO
+!papyrus.png
+!papyrus.desktop
+!papyrus
diff --git a/PKGBUILD b/PKGBUILD
index 6fa2399cd40d..95e845cc3cb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,48 @@
-# Maintainer: Tomas Jasek <tomsik68(at)gmail(dot)com>
+# Maintainer: Gabriel Guldner <gabriel at guldner dot eu>
-pkgname="papyrus"
-pkgver="2.0.2"
+# Contributor: Tomas Jasek <tomsik68(at)gmail(dot)com>
+# Contributor: Alex Brinister <alex_brinister at yahoo dot com>
+
+pkgname='papyrus'
+pkgver='6.6.0'
+_eclipsever='2023-12'
pkgrel=1
-pkgdesc="Graphical editing tool for UML based on eclipse."
-arch=('i686' 'x86_64')
-url="http://www.eclipse.org/papyrus/"
+pkgdesc='Graphical editing tool for UML based on eclipse.'
+arch=('x86_64')
+url='http://www.eclipse.org/papyrus/'
license=('EPL')
groups=()
-depends=('java-runtime')
+depends=(python perl bash)
makedepends=(tar)
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-_eclipsever="neon"
-source_i686=("http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/modeling/mdt/papyrus/rcp/${_eclipsever}/${pkgver}/papyrus-${_eclipsever}-${pkgver}-linux32.tar.gz")
-md5sums_i686=('55ab4ea4cc6da06fbdea4e2659f49498')
-md5sums_x86_64=('6304576c21d5560f9dd1d112e7c4364b')
-source_x86_64=("http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/modeling/mdt/papyrus/rcp/${_eclipsever}/${pkgver}/papyrus-${_eclipsever}-${pkgver}-linux64.tar.gz")
-noextract=()
+provides=('papyrus')
+conflicts=('papyrus')
+sha256sums=('f5c3509e67f852214df53f9672b37bae6deb51df16ebb44da4038e25ca16a5d8'
+ '0bf0ff5eacc3e955a01c171cc21d8c989707ed9eee668ce176d67cfae06c8608'
+ '255f1d8b0277bb9e4a3f84d09294fe34a54485b29f67220733343f37db052b94'
+ '45387c39208b4e18f70059059729dfd06ed4c3393065aebd299072c6eec888ea')
+source=(
+ "http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/modeling/mdt/papyrus/rcp/${_eclipsever}/${pkgver}/papyrus-${_eclipsever}-${pkgver}-linux64.tar.gz"
+ "papyrus.png"
+ "papyrus.desktop"
+ "papyrus"
+)
build() {
- cd $srcdir
- tar -xvzf papyrus-${_eclipsever}-${pkgver}-linux*.tar.gz
- mkdir -p $srcdir/usr/bin/
- echo -e '#!/bin/sh\nexec /usr/lib/papyrus/papyrus' > $srcdir/usr/bin/papyrus
+ cd "$srcdir/Papyrus"
}
package() {
- cd $srcdir
- mkdir -p $pkgdir/usr/lib/papyrus
- mv $srcdir/Papyrus/* $pkgdir/usr/lib/papyrus/
- mkdir -p $pkgdir/usr/bin/
- install -m775 $srcdir/usr/bin/papyrus $pkgdir/usr/bin/papyrus
+ cd "$srcdir"
+ mkdir -p "$pkgdir/usr/lib/papyrus"
+ mkdir -p "$pkgdir/usr/bin/"
+ mkdir -p "$pkgdir/usr/share/icons"
+ mkdir -p "$pkgdir/usr/share/applications"
+
+ install -m644 papyrus.png "$pkgdir/usr/share/icons/"
+ install -m755 papyrus.desktop "$pkgdir/usr/share/applications/"
+
+ cd "$srcdir/Papyrus"
+ find . -type f -exec install -vDm755 {} "$pkgdir/usr/lib/papyrus/"{} \;
+
+ install -m755 "$srcdir/papyrus" "$pkgdir/usr/bin/papyrus"
}
diff --git a/papyrus b/papyrus
new file mode 100644
index 000000000000..c4eab369edc1
--- /dev/null
+++ b/papyrus
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+exec /usr/lib/papyrus/papyrus \ No newline at end of file
diff --git a/papyrus.desktop b/papyrus.desktop
new file mode 100644
index 000000000000..5042721f9864
--- /dev/null
+++ b/papyrus.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Categories=Development;Office;ProjectManagement;
+Comment=Papyrus is an open-source UML tool based on Eclipse.
+Exec=/usr/bin/papyrus
+GenericName=UML Designer
+Icon=/usr/share/icons/papyrus.png
+Name=Eclipse Papyrus
+StartupNotify=true
+Terminal=false
+Type=Application
+Version=1.1
diff --git a/papyrus.png b/papyrus.png
new file mode 100644
index 000000000000..804639d5f742
--- /dev/null
+++ b/papyrus.png
Binary files differ