summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--Changelog13
-rw-r--r--PKGBUILD35
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75af73f18ad3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = parallel-python
+ pkgdesc = Parallel and distributed programming for Python
+ pkgver = 1.6.4
+ pkgrel = 1
+ url = http://www.parallelpython.com/
+ changelog = Changelog
+ arch = any
+ license = BSD
+ makedepends = python2-distribute
+ depends = python2
+ source = http://www.parallelpython.com/downloads/pp/pp-1.6.4.tar.gz
+ md5sums = efadf289d3c94961b6de7373d3f8be38
+
+pkgname = parallel-python
+
diff --git a/Changelog b/Changelog
new file mode 100644
index 000000000000..2a58bc99b9a0
--- /dev/null
+++ b/Changelog
@@ -0,0 +1,13 @@
+2012-12-21 Aaron DeVore <aaron.devore@gmail.com> (1.6.3-1)
+- Version bump to 1.6.3
+- Add makedepends=(python2-distribute)
+2012-06-17 Aaron DeVore <aaron.devore@gmail.com> (1.6.2-1)
+- Version bump to 1.6.2
+- Quotes around all ${pkg,src}dir references
+- Move license file install to package()
+- Install man page, docs
+2011-03-19 Aaron DeVore <aaron.devore@gmail.com> (1.6.1-1)
+- Bump upstream version to 1.6.1
+- Change Python dependency to python2
+- Change architecture to any
+- Added Changelog
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ce51979eee1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
+# Contributor: Chris Baker <baker.chris.3@gmail.com>
+pkgname=parallel-python
+_pkgname=pp
+pkgver=1.6.4
+pkgrel=1
+pkgdesc="Parallel and distributed programming for Python"
+arch=(any)
+url="http://www.parallelpython.com/"
+license=('BSD')
+depends=(python2)
+makedepends=(python2-distribute)
+changelog=Changelog
+source=(http://www.parallelpython.com/downloads/$_pkgname/$_pkgname-$pkgver.tar.gz)
+md5sums=('efadf289d3c94961b6de7373d3f8be38')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir"
+ install -Dm 644 "COPYING" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm 644 "doc/ppserver.1" "${pkgdir}/usr/share/man/man1/ppserver.1"
+ install -m 644 -d "$pkgdir/usr/share/doc/$pkgname"
+ cp -R examples "$pkgdir/usr/share/doc/$pkgname/"
+ chmod -R 755 "$pkgdir/usr/share/doc/$pkgname"
+ # Shebang fix for examples
+ find "$pkgdir/usr/share/doc/" -name "*.py" -exec \
+ sed -i '1s/python[[:space:]]*/python2/' {} \;
+}
+