summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rw-r--r--parallels12-tools.install18
3 files changed, 30 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18e9b8fceaf9..b77ccd38a104 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = parallels12-tools
pkgdesc = Parallels virtualization integration services & drivers
pkgver = 12.2.1.41615
- pkgrel = 2
+ pkgrel = 3
url = https://parallels.com
arch = x86_64
license = custom: commercial
@@ -26,6 +26,7 @@ pkgbase = parallels12-tools
source = dir://parallels12-tools/installer/prl-x11.service
source = dir://parallels12-tools/installer/prlfsmountd.sh
source = dir://parallels12-tools/installer/prl-functions.sh
+ source = dir://parallels12-tools/installer/xserver-config.py
sha1sums = fdd278b5caee0647f1c062512fb83e1da4d5fdb2
sha1sums = fa61d1eddb0d6c2130c3dbb9166e80b71c988584
sha1sums = 52a6c4b6cd493aac8c932a77a25efc17e0e075e5
@@ -39,8 +40,10 @@ pkgbase = parallels12-tools
sha1sums = ff52471a3c6acec6f4a59e2a8f2aff6a937bf09e
sha1sums = b3e540bd8b1a96bfff81e1fd7f90ab978f504475
sha1sums = 524a64269bd1204415e7133e2e5ae821e5e03f2e
+ sha1sums = d33c38b0ad1b46b96274ccb7f72c5efe058d3bf7
pkgname = parallels12-tools
+ install = parallels12-tools.install
provides = parallels-tools
conflicts = xorg-server<1.16
conflicts = X-ABI-VIDEODRV_VERSION<23
diff --git a/PKGBUILD b/PKGBUILD
index f2ebb30d0bc8..aa9ec5529fd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=parallels12-tools
pkgname=(parallels12-tools parallels12-tools-dkms)
pkgver=12.2.1.41615
-pkgrel=2
+pkgrel=3
pkgdesc="Parallels virtualization integration services & drivers"
arch=('x86_64')
url="https://parallels.com"
@@ -33,6 +33,7 @@ source=(
dir://${pkgbase}/installer/prl-x11.service
dir://${pkgbase}/installer/prlfsmountd.sh
dir://${pkgbase}/installer/prl-functions.sh
+ dir://${pkgbase}/installer/xserver-config.py
)
sha1sums=('fdd278b5caee0647f1c062512fb83e1da4d5fdb2'
@@ -47,9 +48,11 @@ sha1sums=('fdd278b5caee0647f1c062512fb83e1da4d5fdb2'
'8a20a07b905a5dcdd0b182844ff781344b78a8b5'
'ff52471a3c6acec6f4a59e2a8f2aff6a937bf09e'
'b3e540bd8b1a96bfff81e1fd7f90ab978f504475'
- '524a64269bd1204415e7133e2e5ae821e5e03f2e')
+ '524a64269bd1204415e7133e2e5ae821e5e03f2e'
+ 'd33c38b0ad1b46b96274ccb7f72c5efe058d3bf7')
package_parallels12-tools() {
+ install=parallels12-tools.install
provides=(parallels-tools)
conflicts+=(parallels-tools)
@@ -74,8 +77,8 @@ package_parallels12-tools() {
install -m 0755 prlfsmountd.sh "${pkgdir}/usr/bin/prlfsmountd"
- install -d -m 0755 "${pkgdir}/etc/X11/xorg.conf.d"
- install -m 0644 prlmouse.conf "${pkgdir}/etc/X11/xorg.conf.d/50-prlmouse.conf"
+ install -d -m 0755 "${pkgdir}/usr/share/X11/xorg.conf.d"
+ install -m 0644 prlmouse.conf "${pkgdir}/usr/share/X11/xorg.conf.d/50-prlmouse.conf"
install -d -m 0755 "${pkgdir}/usr/share/man/man8"
install -m 0644 mount.prl_fs.8 "${pkgdir}/usr/share/man/man8"
@@ -99,6 +102,7 @@ package_parallels12-tools() {
install -d -m 0755 "${pkgdir}/usr/lib/parallels-tools/installer"
install -m 0644 prl-functions.sh "${pkgdir}/usr/lib/parallels-tools/installer"
+ install -m 0755 xserver-config.py "${pkgdir}/usr/lib/parallels-tools/installer"
# These have very strange /usr/local rpaths, strip them out
#chrpath -d "${pkgdir}/usr/lib/libglx.so.1.0.0"
diff --git a/parallels12-tools.install b/parallels12-tools.install
new file mode 100644
index 000000000000..2c03b7e3fe09
--- /dev/null
+++ b/parallels12-tools.install
@@ -0,0 +1,18 @@
+x11_conf=/usr/share/X11/xorg.conf.d/40-prltools.conf
+x11_ver=1.19
+
+## arg 1: the new package version
+post_install() {
+ python /usr/lib/parallels-tools/installer/xserver-config.py xorg "$x11_ver" '' "$x11_conf"
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ python /usr/lib/parallels-tools/installer/xserver-config.py xorg "$x11_ver" '' "$x11_conf"
+}
+
+## arg 1: the old package version
+pre_remove() {
+ rm -f "$x11_conf"
+}