summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD33
2 files changed, 25 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6515b5a7e9e..f169dd83f105 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = parcellite-git
pkgdesc = Lightweight GTK+ clipboard manager (git version)
- pkgver = 1.2.1.r11.fa54161
+ pkgver = 1.2.2.r0.3c3ef48
pkgrel = 1
url = https://github.com/rickyrockrat/parcellite
arch = x86_64
license = GPL3
makedepends = intltool
makedepends = git
+ makedepends = psmisc
depends = gtk2
optdepends = xdotool: auto-paste support
provides = parcellite
conflicts = parcellite
- source = parcellite-git::git://github.com/rickyrockrat/parcellite
- sha256sums = SKIP
+ source = parcellite-git::git+https://github.com/rickyrockrat/parcellite
+ sha512sums = SKIP
pkgname = parcellite-git
-
diff --git a/PKGBUILD b/PKGBUILD
index eda0e547d556..75731dcc88b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,46 @@
# Contributor: Alexander Fehr <pizzapunk gmail com>
pkgname=parcellite-git
-pkgver=1.2.1.r11.fa54161
+pkgver=1.2.2.r0.3c3ef48
pkgrel=1
pkgdesc="Lightweight GTK+ clipboard manager (git version)"
arch=('x86_64')
-url="https://github.com/rickyrockrat/parcellite"
+url="https://github.com/rickyrockrat/${pkgname%%-*}"
license=('GPL3')
depends=('gtk2')
-makedepends=('intltool' 'git')
+makedepends=('intltool'
+ 'git'
+ 'psmisc')
optdepends=('xdotool: auto-paste support')
conflicts=('parcellite')
provides=('parcellite')
-source=("$pkgname"::'git://github.com/rickyrockrat/parcellite')
-sha256sums=('SKIP')
+source=("$pkgname::git+https://github.com/rickyrockrat/${pkgname%%-*}")
+sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
+ cd "${srcdir}/${pkgname}"
git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/$pkgname"
- autoreconf -i
+ cd "${srcdir}/${pkgname}"
+ touch src/config.simple.h
}
build() {
- cd "$srcdir/$pkgname"
- ./configure --prefix=/usr --sysconfdir=/etc
+ cd "${srcdir}/${pkgname}"
+ test -x configure || (
+ (sleep 5; killall gettextize) &
+ ./autogen.sh
+ )
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-appindicator=no
make
}
package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" install
}