summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53dab250ed51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Jun 26 22:29:27 UTC 2017
+pkgbase = parlatype
+ pkgdesc = GNOME audio player for transcription
+ pkgver = 1.5
+ pkgrel = 1
+ url = https://gkarsay.github.io/parlatype/
+ arch = any
+ license = GPL
+ depends = intltool
+ depends = gobject-introspection-runtime
+ depends = yelp-tools
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ source = https://github.com/gkarsay/parlatype/releases/download/v1.5/parlatype-1.5.tar.gz
+ md5sums = 8de6ae7bb0f261b4f48effbe133684c5
+
+pkgname = parlatype
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d57196514b07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Guillaume Hayot <ghayot@postblue.info>
+pkgname=parlatype
+pkgver=1.5
+pkgrel=1
+pkgdesc="GNOME audio player for transcription"
+arch=('any')
+url="https://gkarsay.github.io/parlatype/"
+license=('GPL')
+depends=('intltool' 'gobject-introspection-runtime' 'yelp-tools' 'gst-plugins-base' 'gst-plugins-good')
+source=("https://github.com/gkarsay/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+noextract=()
+md5sums=('8de6ae7bb0f261b4f48effbe133684c5')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ autoreconf
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}