summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0401ce1a48a1..1d556eafca3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
# Generated by mksrcinfo v8
-# Mon Aug 7 23:05:08 UTC 2017
+# Mon Nov 20 11:07:22 UTC 2017
pkgbase = parlatype
pkgdesc = GNOME audio player for transcription
- pkgver = 1.5.1
+ pkgver = 1.5.3
pkgrel = 1
url = https://gkarsay.github.io/parlatype/
arch = any
license = GPL
- makedepends = gobject-introspection
makedepends = libreoffice
makedepends = yelp-tools
makedepends = intltool
- makedepends = glade
- makedepends = gtk-doc
+ makedepends = gobject-introspection
depends = gtk3
depends = gst-plugins-base
depends = gst-plugins-good
optdepends = libreoffice: LibreOffice macros
- source = https://github.com/gkarsay/parlatype/releases/download/v1.5.1/parlatype-1.5.1.tar.gz
- md5sums = d1147b72ea3090e63253eb2b089031ec
+ source = https://github.com/gkarsay/parlatype/releases/download/v1.5.3/parlatype-1.5.3.tar.gz
+ sha256sums = 584a739770e85dd91249fbb716aafdf490b325e2eea393857af80a16f7080fd4
pkgname = parlatype
diff --git a/PKGBUILD b/PKGBUILD
index bd8156abad9c..3ecc19f072ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Guillaume Hayot <ghayot@postblue.info>
pkgname=parlatype
-pkgver=1.5.1
+pkgver=1.5.3
pkgrel=1
pkgdesc="GNOME audio player for transcription"
arch=('any')
url="https://gkarsay.github.io/parlatype/"
license=('GPL')
depends=('gtk3' 'gst-plugins-base' 'gst-plugins-good')
-makedepends=('gobject-introspection' 'libreoffice' 'yelp-tools' 'intltool' 'glade' 'gtk-doc')
+makedepends=('libreoffice' 'yelp-tools' 'intltool' 'gobject-introspection')
+# makedepends=('libreoffice' 'yelp-tools' 'intltool' 'gobject-introspection' 'glade' 'gtk-doc')
optdepends=('libreoffice: LibreOffice macros')
source=("https://github.com/gkarsay/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('1cc0847968911a27d9560d793635945bcc2cbf83a5e579c24c37c66c333da584')
+sha256sums=('584a739770e85dd91249fbb716aafdf490b325e2eea393857af80a16f7080fd4')
prepare() {
cd "$pkgname-$pkgver"
@@ -19,14 +20,18 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
autoreconf
- # Parlatype ships its own library, libparlatype. Developers might be interested in having a library documentation,
- # gobject introspection and a glade catalog for the widgets. These are the configure options:
- # --enable-gtk-doc: install library documentation (default: no)
+ # Parlatype ships its own library, libparlatype.
+ # Developers might be interested in having a library documentation, gobject introspection
+ # and a glade catalog for the widgets.
+ # These are the configure options:
+ # --with-libreoffice: install LibreOffice macros (default: yes)
# --enable-introspection: install gobject introspection (default: yes)
+ # --enable-tests: build unit tests (default: yes)
+ # --enable-gtk-doc: install library documentation (default: no)
# --enable-glade-catalog: install a glade catalog (default: no)
- # --with-libreoffice: install LibreOffice macros (default: yes)
+ # --enable-code-coverage: enable gcov/lcov code coverage (default: no)
# If you want the program only, you would use --prefix=/usr --disable-introspection.
- ./configure --prefix=/usr --enable-gtk-doc --enable-glade-catalog
+ ./configure --prefix=/usr --disable-introspection --disable-tests
make
}