summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore28
-rw-r--r--.gitignore_append2
-rw-r--r--PKGBUILD39
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c741bc6525d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = partialzipbrowser-git
+ pkgdesc = Commandline tool for browsing and downloading files from zip files on remote webserver - git version
+ pkgver = 1.0.r26.g7c43bde
+ pkgrel = 1
+ url = https://github.com/tihmstar/partialZipBrowser
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ depends = curl
+ depends = libfragmentzip
+ provides = partialzipbrowser
+ conflicts = partialzipbrowser
+ source = git+https://github.com/tihmstar/partialZipBrowser.git
+ sha256sums = SKIP
+
+pkgname = partialzipbrowser-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..88a41b67b3e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,28 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+# archlinuxpackages linux
+partialZipBrowser
diff --git a/.gitignore_append b/.gitignore_append
new file mode 100644
index 000000000000..53f9e777b28c
--- /dev/null
+++ b/.gitignore_append
@@ -0,0 +1,2 @@
+# archlinuxpackages linux
+partialZipBrowser
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc056dbf0260
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: 0x9fff00 <0x9fff00+git@protonmail.ch>
+
+_name=partialZipBrowser
+_pkgname=${_name,,}
+pkgname=$_pkgname-git
+pkgver=1.0.r26.g7c43bde
+pkgrel=1
+pkgdesc='Commandline tool for browsing and downloading files from zip files on remote webserver - git version'
+arch=('x86_64')
+url="https://github.com/tihmstar/$_name"
+license=('LGPL3')
+# libfragmentzip's .pc file causes this to link to its dependencies (curl, libzip and zlib)
+# depend on curl since it's actually needed but skip the others
+depends=('curl' 'libfragmentzip')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_name"
+
+ # 's/^v//' removes 'v' prefix
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_name"
+
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_name"
+
+ make DESTDIR="$pkgdir/" install
+}