summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD19
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ade5aeb7ed3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pass-rotate
+ pkgdesc = A tool and library for rotating your password on online services
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/SirCmpwn/pass-rotate
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-beautifulsoup4
+ depends = python-docopt
+ depends = python-requests
+ depends = python-html5lib
+ conflicts = pass-rotate-git
+ options = !emptydirs
+ source = https://github.com/SirCmpwn/pass-rotate/archive/0.1.tar.gz
+ sha512sums = 3c206727439f674cc8eb0429d4adcfca607f3c5187fec7cfee3a7b8e6b461d473955bd68cf159a3f88bb5b6c6e2be5f69f131f187d74ef0228d62817247b4696
+
+pkgname = pass-rotate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3d36682dce8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Alexandre Pujol <alexandre@pujol.io>
+
+pkgname='pass-rotate'
+pkgver=0.1
+pkgrel=1
+pkgdesc=' A tool and library for rotating your password on online services'
+arch=('any')
+url='https://github.com/SirCmpwn/pass-rotate'
+license=('MIT')
+depends=('python' 'python-beautifulsoup4' 'python-docopt' 'python-requests' 'python-html5lib')
+conflicts=("${pkgname}-git")
+source=(https://github.com/SirCmpwn/${pkgname}/archive/${pkgver}.tar.gz)
+sha512sums=('3c206727439f674cc8eb0429d4adcfca607f3c5187fec7cfee3a7b8e6b461d473955bd68cf159a3f88bb5b6c6e2be5f69f131f187d74ef0228d62817247b4696')
+options=(!emptydirs)
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}