summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42d3bc3b114e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = passff-host-librewolf-git
+ pkgdesc = Host app for the WebExtension PassFF. Ported to LibreWolf.
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/passff/passff-host
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = jq
+ depends = python
+ conflicts = passff-host
+ conflicts = passff-host-git
+ source = passff-host::git+https://github.com/passff/passff-host.git
+ sha384sums = SKIP
+
+pkgname = passff-host-librewolf-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba0ae9773778
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: JeppeX <jesperi dot luoto at gmail dot com>
+# Upstream maintainer: Willem Mulder <14mRh4X0r@gmail.com>
+
+_pkgname=passff-host
+pkgname=$_pkgname-librewolf-git
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Host app for the WebExtension PassFF. Ported to LibreWolf."
+arch=(any)
+url="https://github.com/passff/passff-host"
+license=('GPL2')
+depends=('python')
+makedepends=(git jq)
+conflicts=("$_pkgname" 'passff-host-git')
+source=("$_pkgname::git+https://github.com/passff/passff-host.git")
+sha384sums=('SKIP')
+
+package() {
+ cd "$_pkgname"
+
+ sed -i -e s/_VERSIONHOLDER_/${pkgver}/g src/passff.py
+
+ install -Dm755 src/passff.py \
+ "${pkgdir}/usr/lib/librewolf/native-messaging-hosts/passff.py"
+ jq '.path = "/usr/lib/librewolf/native-messaging-hosts/passff.py"' src/passff.json \
+ > "${pkgdir}/usr/lib/librewolf/native-messaging-hosts/passff.json"
+}
+
+# vim:set ts=2 sw=2 et:
+