summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Fixed-broken-Linux-Makefile-based-build.patch107
-rw-r--r--PKGBUILD15
3 files changed, 125 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37de7392879f..3840c4bceedf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Feb 15 18:20:04 UTC 2016
+# Thu Mar 10 16:49:40 UTC 2016
pkgbase = passwordsafe
pkgdesc = Simple & Secure Password Management
- pkgver = 0.97BETA
- pkgrel = 3
+ pkgver = 0.98.1BETA
+ pkgrel = 1
url = https://pwsafe.org/
install = passwordsafe.install
arch = i686
@@ -21,10 +21,12 @@ pkgbase = passwordsafe
conflicts = passwordsafe-git
conflicts = pwsafe
conflicts = pwsafe-gui
- source = https://github.com/pwsafe/pwsafe/releases/download/0.97BETA/pwsafe-0.97BETA-src.tgz
- source = https://github.com/pwsafe/pwsafe/releases/download/0.97BETA/pwsafe-0.97BETA-src.tgz.sig
- sha1sums = ee0d26c0114e4de46a064b2cbcfe4700ddfaa11d
+ source = https://github.com/pwsafe/pwsafe/releases/download/0.98.1BETA/pwsafe-0.98.1BETA-src.tgz
+ source = https://github.com/pwsafe/pwsafe/releases/download/0.98.1BETA/pwsafe-0.98.1BETA-src.tgz.sig
+ source = 0001-Fixed-broken-Linux-Makefile-based-build.patch
+ sha1sums = 505f0d24376ae0dc886958869ea8e2f2e14d85ca
sha1sums = SKIP
+ sha1sums = 8dcb2d5b9d7f8eb58d7f6b54b23e2a4eaa2b981c
pkgname = passwordsafe
diff --git a/0001-Fixed-broken-Linux-Makefile-based-build.patch b/0001-Fixed-broken-Linux-Makefile-based-build.patch
new file mode 100644
index 000000000000..7ddd73a2498b
--- /dev/null
+++ b/0001-Fixed-broken-Linux-Makefile-based-build.patch
@@ -0,0 +1,107 @@
+From eea4ef611110f34f184b8d49d1832beb2e0f5cec Mon Sep 17 00:00:00 2001
+From: ronys <ronys@pwsafe.org>
+Date: Tue, 8 Mar 2016 22:11:35 +0200
+Subject: [PATCH] Fixed broken Linux Makefile-based build
+
+Which required supporting point revisions correctly.
+---
+ Makefile.linux | 3 ++-
+ src/ui/wxWidgets/Makefile | 10 +++++++---
+ src/ui/wxWidgets/about.cpp | 2 +-
+ src/ui/wxWidgets/pwsafeapp.cpp | 2 --
+ src/ui/wxWidgets/version.cpp | 18 ++++++++++++------
+ 5 files changed, 22 insertions(+), 13 deletions(-)
+
+diff --git a/Makefile.linux b/Makefile.linux
+index 5762a47..6acf069 100644
+--- a/Makefile.linux
++++ b/Makefile.linux
+@@ -2,7 +2,8 @@
+ # Toplevel Makefile for Linux build of PasswordSafe
+
+ export VER_MAJOR := 0
+-export VER_MINOR := 98.1
++export VER_MINOR := 98
++export VER_REV := 1
+ export VER_SPECIAL := BETA
+
+ # Since we use wxWidgets 3.x, while many distros still provide 2.8
+diff --git a/src/ui/wxWidgets/Makefile b/src/ui/wxWidgets/Makefile
+index b8e4ed5..9bd3cd8 100644
+--- a/src/ui/wxWidgets/Makefile
++++ b/src/ui/wxWidgets/Makefile
+@@ -240,9 +240,13 @@ $(DEPDIR)/%.d: %.cpp version.h
+ $(RM) $@.$$$$
+
+ version.h: always
+- @../../../Misc/mkversion.pl MAJOR=$(VER_MAJOR) MINOR=$(VER_MINOR) SPECIAL=$(VER_SPECIAL) \
+- version.in $@
+-
++ifdef VER_REV
++ @../../../Misc/mkversion.pl MAJOR=$(VER_MAJOR) MINOR=$(VER_MINOR) REV=$(VER_REV) \
++ SPECIAL=$(VER_SPECIAL) version.in $@
++else
++ @../../../Misc/mkversion.pl MAJOR=$(VER_MAJOR) MINOR=$(VER_MINOR) \
++ SPECIAL=$(VER_SPECIAL) version.in $@
++endif
+ -include $(SOURCES:%.cpp=$(DEPDIR)/%.d)
+
+
+diff --git a/src/ui/wxWidgets/about.cpp b/src/ui/wxWidgets/about.cpp
+index 6742a39..a101136 100644
+--- a/src/ui/wxWidgets/about.cpp
++++ b/src/ui/wxWidgets/about.cpp
+@@ -328,7 +328,7 @@ void CAbout::CheckNewVersion()
+ }
+ stringT latest;
+ if (status == CheckVersion::UP2DATE) {
+- CheckVersion cv(MAJORVERSION, MINORVERSION, 0);
++ CheckVersion cv(MAJORVERSION, MINORVERSION, REVISION);
+ status = cv.CheckLatestVersion(latest_xml, latest);
+ }
+ m_newVerStatus->Clear();
+diff --git a/src/ui/wxWidgets/pwsafeapp.cpp b/src/ui/wxWidgets/pwsafeapp.cpp
+index fcf17f4..27c9e95 100644
+--- a/src/ui/wxWidgets/pwsafeapp.cpp
++++ b/src/ui/wxWidgets/pwsafeapp.cpp
+@@ -274,8 +274,6 @@ bool PwsafeApp::OnInit()
+ wxFileSystem::AddHandler(new wxArchiveFSHandler);
+
+ SetAppName(pwsafeAppName);
+- m_core.SetApplicationNameAndVersion(tostdstring(pwsafeAppName),
+- DWORD((MINORVERSION << 16) | MAJORVERSION));
+ PWSprefs::SetReporter(&aReporter);
+ PWScore::SetReporter(&aReporter);
+ PWScore::SetAsker(&anAsker);
+diff --git a/src/ui/wxWidgets/version.cpp b/src/ui/wxWidgets/version.cpp
+index cc9e726..d3af576 100644
+--- a/src/ui/wxWidgets/version.cpp
++++ b/src/ui/wxWidgets/version.cpp
+@@ -17,12 +17,18 @@
+ #endif
+
+ const wxString pwsafeAppName(APPNAME);
+-#ifndef _DEBUG
+-const wxString pwsafeVersionString = wxString::Format(wxString(_T("v%d.%d (%ls) %ls")),
+- MAJORVERSION, MINORVERSION,
+- _T(VCS_VERSION), SPECIALBUILD);
++#ifdef _DEBUG
++const wchar_t *debstr = L"[debug] ";
++#else
++const wchar_t *debstr = L"";
++#endif
++
++#if defined(REVISION) && (REVISION != 0)
++const wxString pwsafeVersionString = wxString::Format(wxString(_T("v%d.%d.%d (%ls) %ls%ls")),
++ MAJORVERSION, MINORVERSION, REVISION,
++ _T(VCS_VERSION), debstr, SPECIALBUILD);
+ #else
+-const wxString pwsafeVersionString = wxString::Format(wxString(_T("v%d.%d (%ls) [debug] %ls")),
++const wxString pwsafeVersionString = wxString::Format(wxString(_T("v%d.%d (%ls) %ls%ls")),
+ MAJORVERSION, MINORVERSION,
+- _T(VCS_VERSION), SPECIALBUILD);
++ _T(VCS_VERSION), debstr, SPECIALBUILD);
+ #endif
+--
+2.7.2
+
diff --git a/PKGBUILD b/PKGBUILD
index a259aac6fb02..75beea52acb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
_pkgname=pwsafe
pkgname=passwordsafe
-_pkgver=0.97
+_pkgver=0.98.1
pkgver="$_pkgver"BETA
-pkgrel=3
+pkgrel=1
pkgdesc="Simple & Secure Password Management"
arch=('i686' 'x86_64')
url="https://pwsafe.org/"
@@ -14,15 +14,20 @@ depends=('libxtst' 'wxgtk' 'webkitgtk2' 'yubikey-personalization' 'xerces-c')
makedepends=('zip' 'libxt')
optdepends=('xvkbd: virtual-keyboard support')
conflicts=('passwordsafe-debian' 'passwordsafe-git' 'pwsafe' 'pwsafe-gui')
-source=(https://github.com/pwsafe/pwsafe/releases/download/$pkgver/pwsafe-$pkgver-src.tgz{,.sig})
+source=(https://github.com/pwsafe/pwsafe/releases/download/$pkgver/pwsafe-$pkgver-src.tgz{,.sig}
+ 0001-Fixed-broken-Linux-Makefile-based-build.patch)
install='passwordsafe.install'
validpgpkeys=('A703C1328EABC7B201753BA3919464515CCF8BB3') #Rony Shapiro
-sha1sums=('ee0d26c0114e4de46a064b2cbcfe4700ddfaa11d'
- 'SKIP')
+sha1sums=('505f0d24376ae0dc886958869ea8e2f2e14d85ca'
+ 'SKIP'
+ '8dcb2d5b9d7f8eb58d7f6b54b23e2a4eaa2b981c')
prepare() {
cd "$_pkgname-$pkgver"
+ # https://github.com/pwsafe/pwsafe/issues/79
+ # git format-patch -1 eea4ef6
+ patch -p1 -i ../0001-Fixed-broken-Linux-Makefile-based-build.patch
}
build() {