summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2cd66e5cb99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pastenotifier-git
+ pkgdesc = Simple application showing what is copied to the clipboard, avoids embarassment
+ pkgver = 26.985ca75
+ pkgrel = 1
+ url = https://github.com/sandsmark/pastenotifier
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = kglobalaccel
+ provides = pastenotifier
+ conflicts = pastenotifier
+ source = git+https://github.com/sandsmark/pastenotifier.git
+ md5sums = SKIP
+
+pkgname = pastenotifier-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3496fa30fc90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Martin Sandsmark <martin.sandsmark@kde.org>
+
+pkgname=pastenotifier-git
+pkgver=26.985ca75
+pkgrel=1
+pkgdesc="Simple application showing what is copied to the clipboard, avoids embarassment"
+arch=(i686 x86_64)
+url="https://github.com/sandsmark/pastenotifier"
+license=(GPL3)
+depends=(kglobalaccel)
+makedepends=(git)
+provides=(pastenotifier)
+conflicts=(pastenotifier)
+source=('git+https://github.com/sandsmark/pastenotifier.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd pastenotifier
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../pastenotifier \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}