summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..827d235885bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = paswitch
+ pkgdesc = Switch PulseAudio sink for all applications from the commandline.
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://www.tablix.org/~avian/blog/archives/2012/06/switching_pulseaudio_output_device/
+ arch = x86_64
+ arch = i686
+ license = gpl
+ makedepends = git
+ depends = libpulse
+ provides = paswitch
+ source = paswitch-0.1::git+http://www.tablix.org/~avian/git/paswitch.git
+ md5sums = SKIP
+
+pkgname = paswitch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8c3a5f2ea29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Andy Pieters <Andy@AndyPieters.me.uk>
+pkgname=paswitch
+pkgver=0.1
+pkgrel=1
+epoch=
+pkgdesc="Switch PulseAudio sink for all applications from the commandline."
+arch=(x86_64 i686 )
+url="http://www.tablix.org/~avian/blog/archives/2012/06/switching_pulseaudio_output_device/"
+license=('gpl')
+groups=()
+depends=(libpulse)
+makedepends=(git)
+checkdepends=()
+optdepends=()
+provides=(paswitch)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=($pkgname-$pkgver::git+http://www.tablix.org/~avian/git/paswitch.git)
+
+md5sums=('SKIP') #generate with 'makepkg -g'
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -D paswitch $pkgdir/usr/bin/paswitch
+}