summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 6 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77f88675f295..fc9cdb254db5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = patchbay-git
pkgdesc = An alternative Secure Scuttlebutt client interface that is fully compatible with Patchwork
- pkgver = 7.13.1.r182.g68110fd
+ pkgver = v7.13.1.r195.1378d45
pkgrel = 1
url = https://github.com/ssbc/patchbay
arch = i686
@@ -8,6 +8,7 @@ pkgbase = patchbay-git
license = MIT
makedepends = nodejs
makedepends = npm
+ makedepends = git
depends = libsodium
depends = gtk2
depends = gconf
@@ -20,7 +21,7 @@ pkgbase = patchbay-git
source = run.sh
source = patchbay.desktop
md5sums = SKIP
- md5sums = fae47b2d8539295743f7946ea07393c4
+ md5sums = 6632351cad7b33d94834e9a37f77f727
md5sums = f459479fef0987c5fa81a38b04767ffa
pkgname = patchbay-git
diff --git a/PKGBUILD b/PKGBUILD
index a408214e772e..23a39ffe7206 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Christian Bundy <christianbundy@fraction.io>
pkgname=patchbay-git
-pkgver=7.13.1.r182.g68110fd
+pkgver=7.13.1.r195.1378d45
pkgrel=1
pkgdesc="An alternative Secure Scuttlebutt client interface that is fully compatible with Patchwork "
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ license=('MIT')
provides=('patchbay')
conflicts=('patchbay')
depends=('libsodium' 'gtk2' 'gconf' 'python' 'lib32-gcc-libs')
-makedepends=('nodejs' 'npm')
+makedepends=('nodejs' 'npm' 'git')
options=(!strip)
_srcname=patchbay
@@ -25,18 +25,11 @@ md5sums=('SKIP'
pkgver() {
cd "${_srcname}"
-
- # https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=linux-git&id=e03e86d03543561336930472671ffa3e8b8e8cbd#n34
- git describe --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g;s/\.rc/rc/'
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//g')"
}
build() {
cd "${srcdir}/${_srcname}"
-
- # https://github.com/ssbc/patchbay/issues/211
- npm install --save git://github.com/Happy0/ssb-chess#master
- npm audit fix
-
npm ci
npm run rebuild
}