summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
-rw-r--r--pause.c2
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4d3497f02f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pause
+ pkgdesc = Wait for signal
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://hexawolf.dev/post/pause
+ arch = any
+ license = Unlicense
+ makedepends = dietlibc
+ makedepends = binutils
+ makedepends = gcc
+ provides = pause
+ source = pause.c
+ sha256sums = SKIP
+
+pkgname = pause
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49d3f16b4ce6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Hexawolf <hexawolf@protonmail.com>
+
+pkgname=pause
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Wait for signal"
+arch=('any')
+url="https://hexawolf.dev/post/pause"
+license=('Unlicense')
+makedepends=('dietlibc' 'binutils' 'gcc')
+provides=('pause')
+source=("pause.c")
+sha256sums=('SKIP')
+
+build() {
+ diet -Os gcc -Wl,--gc-sections -ffunction-sections -fdata-sections pause.c -o pause
+ strip -s -R .comment -R .gnu.version pause
+}
+
+package() {
+ install -D -m 755 pause -t "${pkgdir}/usr/bin"
+}
diff --git a/pause.c b/pause.c
new file mode 100644
index 000000000000..110909a88e32
--- /dev/null
+++ b/pause.c
@@ -0,0 +1,2 @@
+#include <unistd.h>
+int main(){pause();} \ No newline at end of file