aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD38
3 files changed, 64 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..b30fe6cdc522
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = paxctl
+ pkgdesc = Manages various PaX related program header flags for Elf32, Elf64, binaries
+ pkgver = 0.9
+ pkgrel = 1
+ url = http://pax.grsecurity.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://pax.grsecurity.net/paxctl-0.9.tar.gz
+ sha256sums = a330ddd812688169802a3ba29e5e3b19956376b8f6f73b8d7e9586eb04423c2e
+
+pkgname = paxctl
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b30fe6cdc522
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = paxctl
+ pkgdesc = Manages various PaX related program header flags for Elf32, Elf64, binaries
+ pkgver = 0.9
+ pkgrel = 1
+ url = http://pax.grsecurity.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://pax.grsecurity.net/paxctl-0.9.tar.gz
+ sha256sums = a330ddd812688169802a3ba29e5e3b19956376b8f6f73b8d7e9586eb04423c2e
+
+pkgname = paxctl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..564672173ecb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributors:
+# sh0 <mee@sh0.org>
+# s1gma <s1gma@mindslicer.com>
+# henning mueller <henning@orgizm.net>
+#
+# Find this package in the AUR:
+# https://aur.archlinux.org/packages/paxctl
+#
+# Please report bugs and feature requests on GitHub:
+# https://github.com/nning/paxctl
+#
+
+pkgname=paxctl
+pkgver=0.9
+pkgrel=1
+pkgdesc='Manages various PaX related program header flags for Elf32, Elf64, binaries'
+url=http://pax.grsecurity.net
+arch=(i686 x86_64)
+license=(GPL)
+depends=()
+source=(http://pax.grsecurity.net/$pkgname-$pkgver.tar.gz)
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -i 's:/sbin:/usr/bin:' Makefile
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+sha256sums=('a330ddd812688169802a3ba29e5e3b19956376b8f6f73b8d7e9586eb04423c2e')