summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD20
-rw-r--r--glibmm.patch11
3 files changed, 31 insertions, 8 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f154df9d79eb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+pkg/
+src/
+*.swp
+*.pkg.tar.xz
+*.src.tar.gz
+
+pcb2gcode/
+
diff --git a/PKGBUILD b/PKGBUILD
index 120dabd2f421..451edb85572a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,35 @@
pkgname=pcb2gcode-git
_pkgname=pcb2gcode
-pkgver=r144.05e093f
+pkgver=r241.eb2a001
pkgrel=1
pkgdesc="Gerber to gcode file converter"
arch=('i686' 'x86_64')
-url="https://github.com/patkan/pcb2gcode"
+url="https://github.com/pcb2gcode/pcb2gcode"
license=('GPL')
makedepends=('git' 'boost')
depends=('gtkmm' 'boost-libs' 'gerbv-git')
provides=('pcb2gcode')
conflicts=('pcb2gcode')
-md5sums=('SKIP')
-source=("$_pkgname"::'git://github.com/pcb2gcode/pcb2gcode.git')
+source=("$_pkgname"::'git://github.com/pcb2gcode/pcb2gcode.git'
+ 'glibmm.patch')
+md5sums=('SKIP'
+ '3cc7d7023d3d89332d88a9eaa97eb8bc')
pkgver() {
cd "$srcdir/$_pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/$_pkgname"
+ patch -p1 -i ../glibmm.patch
+}
+
build() {
cd "$srcdir/$_pkgname"
- libtoolize
- aclocal
- automake --add-missing
- autoreconf
+ autoreconf -i
./configure --prefix=/usr
make -j
}
diff --git a/glibmm.patch b/glibmm.patch
new file mode 100644
index 000000000000..61b7947f55af
--- /dev/null
+++ b/glibmm.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.am 2015-11-18 18:01:02.598535720 +0100
++++ b/Makefile.am 2015-11-18 18:13:52.556536170 +0100
+@@ -34,7 +34,7 @@
+
+ ACLOCAL_AMFLAGS = -I m4
+
+-AM_CPPFLAGS = $(BOOST_CPPFLAGS) $(glibmm_CFLAGS) $(gdkmm_CFLAGS) $(gerbv_CFLAGS)
++AM_CPPFLAGS = $(BOOST_CPPFLAGS) $(glibmm_CFLAGS) $(gdkmm_CFLAGS) $(gerbv_CFLAGS) -std=c++11
+ AM_LDFLAGS = $(BOOST_PROGRAM_OPTIONS_LDFLAGS)
+ LIBS = $(glibmm_LIBS) $(gdkmm_LIBS) $(gerbv_LIBS) $(BOOST_PROGRAM_OPTIONS_LIBS) $(BOOST_REGEX_LIBS)
+