summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO40
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD72
3 files changed, 90 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c271894ce9ac..9ca82888213e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Dec 30 00:21:50 UTC 2015
pkgbase = pcl-git
pkgdesc = a standalone, large scale, open project for 2D/3D image and point cloud processing
- pkgver = r9837.e97b664
+ pkgver = r14353.21b58c1be
pkgrel = 1
url = http://pointclouds.org/
arch = i686
@@ -11,20 +9,42 @@ pkgbase = pcl-git
makedepends = cmake
makedepends = git
depends = boost
+ depends = cuda
depends = eigen
depends = flann
- depends = vtk
- depends = qt5-base
- depends = qt5-webkit
- depends = qhull
+ depends = glew
depends = glu
- depends = python2
- depends = libxt
+ depends = libxcursor
depends = openmpi
+ depends = qhull
+ depends = qt5-base
+ depends = qt5-webengine
+ depends = vtk
+ depends = pugixml
+ depends = fmt
+ depends = python-mpi4py
+ depends = openxr
+ depends = openvr
+ depends = gl2ps
+ depends = adios2
+ depends = verdict
+ depends = liblas
+ depends = openvdb
+ depends = pdal
+ depends = openimagedenoise
+ depends = ospray
+ depends = cli11
+ depends = utf8cpp
+ depends = nlohmann-json
+ depends = openni2
+ depends = ensenso-sdk
+ depends = postgresql
+ depends = gcc12
provides = pcl
conflicts = pcl
source = git+https://github.com/PointCloudLibrary/pcl
+ source = patch-eigen.patch::https://github.com/PointCloudLibrary/pcl/pull/5998.patch
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = pcl-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1d7797dd1d2c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+pcl
+pcl*tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 7101b07533cc..01dbb7ed3e18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,12 @@
# Maintainer: Maarten de Vries <maarten@de-vri.es>
+# Contributor: Yuxin Wu <ppwwyyxxc@gmail.com>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: hauptmech
+# Contributor: figo.zhang
+# Contributor: lubosz
pkgname=pcl-git
-pkgver=r9837.e97b664
+pkgver=r14353.21b58c1be
pkgrel=1
pkgdesc="a standalone, large scale, open project for 2D/3D image and point cloud processing"
arch=(i686 x86_64)
@@ -9,20 +14,47 @@ url="http://pointclouds.org/"
license=('BSD')
depends=(
boost
+ cuda
eigen
flann
- vtk
- qt5-base
- qt5-webkit
- qhull
+ glew
glu
- python2
- libxt
+ libxcursor
openmpi
+ qhull
+ qt5-base
+ qt5-webengine
+ vtk
+ pugixml
+ fmt
+ python-mpi4py
+ openxr
+ openvr
+ gl2ps
+ adios2
+ verdict
+ liblas
+ openvdb
+ pdal
+ openimagedenoise
+ ospray
+ cli11
+ utf8cpp
+ nlohmann-json
+ openni2
+ ensenso-sdk
+ postgresql
+ gcc12
)
makedepends=(cmake git)
-source=(git+https://github.com/PointCloudLibrary/pcl)
-sha256sums=(SKIP)
+source=(
+ git+https://github.com/PointCloudLibrary/pcl
+ patch-eigen.patch::https://github.com/PointCloudLibrary/pcl/pull/5998.patch
+)
+sha256sums=(
+ SKIP
+ SKIP
+)
conflicts=(pcl)
provides=(pcl)
@@ -33,13 +65,16 @@ pkgver() {
}
prepare() {
- rm -rf "$srcdir/build"
- mkdir "$srcdir/build"
+ cd "${srcdir}/pcl"
+ patch -Np1 -i "${srcdir}/patch-eigen.patch" || true
+ mkdir -p "$srcdir/build"
cd "$srcdir/build"
-
cmake "${srcdir}/pcl" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS} -fPIC" \
+ -DCMAKE_SHARED_LINKER_FLAGS="${LDFLAGS} -Wl,--as-needed" \
+ -DCMAKE_EXE_LINKER_FLAGS="${LDFLAGS} -Wl,--as-needed" \
+ -DCMAKE_CUDA_ARCHITECTURES="all" \
-DBUILD_apps=ON \
-DBUILD_apps_cloud_composer=ON \
-DBUILD_apps_in_hand_scanner=ON \
@@ -52,15 +87,20 @@ prepare() {
-DBUILD_cuda_io=ON \
-DBUILD_cuda_apps=ON \
-DBUILD_GPU=ON \
+ -DBUILD_gpu_kinfu=OFF \
+ -DBUILD_gpu_kinfu_large_scale=OFF \
-DBUILD_gpu_surface=ON \
-DBUILD_gpu_tracking=ON \
- -DBUILD_app_3d_rec_framework=ON \
- -DBUILD_simulation=ON
+ -DBUILD_simulation=ON \
+ -DCMAKE_CUDA_COMPILER=/opt/cuda/bin/nvcc \
+ -DCMAKE_CUDA_HOST_COMPILER=/usr/bin/g++-12 \
+ -DCMAKE_MODULE_PATH=/usr/lib/cmake/OpenVDB \
+ -DWITH_QT=QT5 # VTK is still using Qt5
}
build() {
cd "$srcdir/build"
- make
+ make -j$(nproc)
}
package() {