summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--MKPKG5
-rw-r--r--PKGBUILD41
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abc095843605
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = pcsxr-svn
+ pkgdesc = A Sony PlayStation emulator based on the PCSX-df Project
+ pkgver = 1.9.93.r91911
+ pkgrel = 1
+ url = http://pcsxr.codeplex.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = mesa
+ makedepends = subversion
+ depends = gtk3
+ depends = libarchive
+ depends = libcdio
+ depends = libxv
+ depends = sdl2
+ provides = pcsxr
+ conflicts = pcsxr
+ conflicts = pcsx-df
+ source = svn+https://pcsxr.svn.codeplex.com/svn/pcsxr
+ sha256sums = SKIP
+
+pkgname = pcsxr-svn
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..0a7673e1f9c6
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,5 @@
+pkgname=('pcsxr-svn')
+
+check_svn $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cca9e0e102b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Infy <eugene.yudin@gmail.com>
+
+pkgname=pcsxr-svn
+pkgver=1.9.93.r91911
+pkgrel=1
+pkgdesc='A Sony PlayStation emulator based on the PCSX-df Project'
+arch=('i686' 'x86_64')
+url='http://pcsxr.codeplex.com/'
+license=('GPL')
+depends=('gtk3' 'libarchive' 'libcdio' 'libxv' 'sdl2')
+makedepends=('intltool' 'mesa' 'subversion')
+[[ $CARCH == i686 ]] && makedepends+=('nasm')
+provides=('pcsxr')
+conflicts=('pcsxr' 'pcsx-df')
+source=('svn+https://pcsxr.svn.codeplex.com/svn/pcsxr')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pcsxr
+
+ printf "1.9.93.r%s" "$(svnversion)"
+}
+
+build() {
+ cd pcsxr
+
+ chmod +x autogen.sh
+ ./autogen.sh \
+ --prefix='/usr' \
+ --enable-{libcdio,opengl}
+ make
+}
+
+package() {
+ cd pcsxr
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: