summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--RTcmix-pd-LCPLAY-stabilize.patch13
3 files changed, 9 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index daa859d77065..056717164605 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pd-l2ork
pkgdesc = L2Ork (Linux Laptop Orchestra) version of PureData
- pkgver = 20190812.r1771.42cedfa8
- pkgrel = 2
+ pkgver = 20200822.r1790.15f00bbf
+ pkgrel = 1
url = http://l2ork.music.vt.edu/main/?page_id=56
install = pd-l2ork.install
arch = i686
@@ -12,6 +12,7 @@ pkgbase = pd-l2ork
makedepends = libtool
makedepends = git
makedepends = rsync
+ makedepends = python2
depends = bluez-libs
depends = desktop-file-utils
depends = dssi
@@ -53,10 +54,8 @@ pkgbase = pd-l2ork
depends = zlib
conflicts = pd-l2ork
options = !makeflags
- source = pd-l2ork::git+https://github.com/pd-l2ork/pd.git#commit=42cedfa82c8a6aea20caa8b46ed22a98763646f6
- source = RTcmix-pd-LCPLAY-stabilize.patch
+ source = pd-l2ork::git+https://github.com/pd-l2ork/pd.git#commit=15f00bbf096fb86cc13b48a5d6a04286aab711ca
md5sums = SKIP
- md5sums = 39c53063dc18681f29b12c08d9c453aa
pkgname = pd-l2ork
diff --git a/PKGBUILD b/PKGBUILD
index ea6e57d2029e..251a5bc31edf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@
# under /usr/include/pd-l2ork.
pkgname=pd-l2ork
-pkgver=20190812.r1771.42cedfa8
-pkgrel=2
+pkgver=20200822.r1790.15f00bbf
+pkgrel=1
pkgdesc="L2Ork (Linux Laptop Orchestra) version of PureData"
url="http://l2ork.music.vt.edu/main/?page_id=56"
arch=('i686' 'x86_64')
@@ -23,14 +23,12 @@ depends=('bluez-libs' 'desktop-file-utils' 'dssi' 'fftw'
'libxxf86vm' 'libtiff' 'libiec61883' 'libraw1394'
'libv4l' 'libvorbis' 'lua51' 'portaudio'
'smpeg' 'speex' 'stk' 'gtk2' 'tk' 'tkpng' 'vlc' 'xapian-tcl-bindings' 'zlib')
-makedepends=('autoconf' 'automake' 'libtool' 'git' 'rsync')
+makedepends=('autoconf' 'automake' 'libtool' 'git' 'rsync' 'python2')
conflicts=('pd-l2ork')
install=pd-l2ork.install
options=('!makeflags')
-source=("$pkgname::git+https://github.com/pd-l2ork/pd.git#commit=42cedfa82c8a6aea20caa8b46ed22a98763646f6"
- "RTcmix-pd-LCPLAY-stabilize.patch")
-md5sums=('SKIP'
- '39c53063dc18681f29b12c08d9c453aa')
+source=("$pkgname::git+https://github.com/pd-l2ork/pd.git#commit=15f00bbf096fb86cc13b48a5d6a04286aab711ca")
+md5sums=('SKIP')
# Run 'makepkg buildopt=-b' for an incremental build (this skips recompiling
# Gem which takes a *long* time to build). Note that this will only produce a
@@ -50,8 +48,6 @@ prepare() {
git submodule foreach git checkout .
# check out the latest source of all submodules
git submodule update --init
- # make the sources compile with gcc 6.1+
- cd $srcdir/$pkgname/l2ork_addons/rtcmix-in-pd && patch -Np1 < $srcdir/RTcmix-pd-LCPLAY-stabilize.patch
}
build() {
diff --git a/RTcmix-pd-LCPLAY-stabilize.patch b/RTcmix-pd-LCPLAY-stabilize.patch
deleted file mode 100644
index 20f10a8b1669..000000000000
--- a/RTcmix-pd-LCPLAY-stabilize.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/RTcmix-pd-4.0.1.6/insts/std/LPCPLAY/stabilize.cpp b/RTcmix-pd-4.0.1.6/insts/std/LPCPLAY/stabilize.cpp
-index 5753965..9cf85c4 100644
---- a/RTcmix-pd-4.0.1.6/insts/std/LPCPLAY/stabilize.cpp
-+++ b/RTcmix-pd-4.0.1.6/insts/std/LPCPLAY/stabilize.cpp
-@@ -29,7 +29,7 @@ stabilize(float *frameIn, int npoles)
- static Complex jay(0., 1.);
- static Complex tmp;
-
--inline double abs(double x) { return (x >= 0.) ? x : -x; }
-+//inline double abs(double x) { return (x >= 0.) ? x : -x; }
-
- static int
- factor(double *b, long *k4, double *rootr, double *rooti,