summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42d61ae284d5..c026e3f8a7ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,17 @@
# Generated by mksrcinfo v8
-# Fri Sep 30 11:42:49 UTC 2016
+# Tue Oct 17 19:34:07 UTC 2017
pkgbase = pdeath
pkgdesc = Run a command that is killed when its parent exits
- pkgver = 1.0
+ pkgver = 1.1
pkgrel = 1
url = https://github.com/maandree/pdeath
arch = i686
arch = x86_64
license = custom:ISC
- makedepends = glibc
makedepends = linux>=2.1.57
- makedepends = make
- makedepends = coreutils
- makedepends = gcc
- depends = glibc
depends = linux>=2.1.57
- source = https://github.com/maandree/pdeath/archive/1.0.tar.gz
- sha256sums = e9066459fe4af6e6607f45dc119d1c0030893bfdc5b37e753e952678be468250
+ source = pdeath-1.1.tar.gz::https://github.com/maandree/pdeath/archive/1.1.tar.gz
+ sha256sums = 1b236d9768d972611ca4a41c247a8953028e6f80e637b26e7b1086b10989b3d8
pkgname = pdeath
diff --git a/PKGBUILD b/PKGBUILD
index 431bddff6157..de7b99492455 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
-
pkgname=pdeath
-pkgver=1.0
+pkgver=1.1
pkgrel=1
pkgdesc="Run a command that is killed when its parent exits"
arch=(i686 x86_64)
url="https://github.com/maandree/pdeath"
license=('custom:ISC')
-depends=(glibc 'linux>=2.1.57')
-makedepends=(glibc 'linux>=2.1.57' make coreutils gcc)
-source=($url/archive/$pkgver.tar.gz)
-sha256sums=(e9066459fe4af6e6607f45dc119d1c0030893bfdc5b37e753e952678be468250)
-
+depends=('linux>=2.1.57')
+makedepends=('linux>=2.1.57')
+source=($pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
+sha256sums=(1b236d9768d972611ca4a41c247a8953028e6f80e637b26e7b1086b10989b3d8)
build() {
cd "$srcdir/$pkgname-$pkgver"
- make
+ make PREFIX=/usr
}
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make check
+}
package() {
cd "$srcdir/$pkgname-$pkgver"
- make install DESTDIR="$pkgdir"
+ make install PREFIX=/usr DESTDIR="$pkgdir"
}
-