summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD33
2 files changed, 12 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bc9bc9ae4d8..0c787ddada5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,9 @@ pkgbase = pdfcmd
url = https://github.com/bulletmark/pdfcmd
arch = any
license = GPL3
- makedepends = python-pip
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-wheel
depends = python>=3.5
depends = python-pypdf2>=2.0.0
diff --git a/PKGBUILD b/PKGBUILD
index 873b17a21595..c7fe70c269de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,36 +4,21 @@ pkgver=1.5
pkgrel=1
pkgdesc='Utility to perform commands on PDF files.'
url="https://github.com/bulletmark/$pkgname"
-license=("GPL3")
-arch=("any")
+license=(GPL3)
+arch=(any)
depends=("python>=3.5" "python-pypdf2>=2.0.0")
-makedepends=("python-pip" "python-wheel")
+makedepends=(python-setuptools python-build python-installer python-wheel)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha1sums=('136f3418de657fffc888a6d73c8f4cc4dae131bc')
-package() {
+build() {
cd "$srcdir/$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
- PIP_CONFIG_FILE=/dev/null pip install \
- --root="$pkgdir" \
- --isolated \
- --ignore-installed \
- --no-deps \
- --disable-pip-version-check \
- --no-python-version-warning \
- --no-warn-script-location \
- --no-cache-dir \
- --no-compile \
- --progress-bar=off \
- --root-user-action=ignore \
- .
-
- local pdir=$(python -c "import site; print(site.getsitepackages()[0])")
- local _pkgname="${pkgname//-/_}"
- cd "$pkgdir/$pdir"
- rm -f $_pkgname-*.dist-info/direct_url.json
- sed -i "/\/direct_url.json,/d" $_pkgname-*.dist-info/RECORD
- python -O -m compileall -q .
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
# vim:set ts=2 sw=2 et: