summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c1a5e0400ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pdfedit-bin
+ pkgdesc = Full featured editor for manipulating PDF documents (built from Debian binaries)
+ pkgver = 0.4.5
+ pkgrel = 3
+ url = http://pdfedit.petricek.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt3
+ depends = t1lib
+ depends = gsfonts
+ depends = zlib
+ provides = pdfedit
+ conflicts = pdfedit
+ source = http://ftp.us.debian.org/debian/pool/main/p/pdfedit/pdfedit_0.4.5-1_amd64.deb
+ sha256sums = bc30c4f0727c826851b18879e1c720c62401d8808ec28460bbdd33400fe2c37b
+
+pkgname = pdfedit-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bf964d35168
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Submitter: McNoggins < gagnon88 at gmail >
+pkgname=pdfedit-bin
+pkgver=0.4.5
+_debpkgrel=1
+pkgrel=3
+pkgdesc="Full featured editor for manipulating PDF documents (built from Debian binaries)"
+url="http://pdfedit.petricek.net/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('qt3' 't1lib' 'gsfonts' 'zlib')
+provides=('pdfedit')
+conflicts=('pdfedit')
+
+if [[ $CARCH == i686 ]]; then
+ _debarch=i386
+ sha256sums=('f85f26e213f3d056ccffdf80b9fe2fc1161258b64f745b212003af079f129be4')
+else
+ _debarch=amd64
+ sha256sums=('bc30c4f0727c826851b18879e1c720c62401d8808ec28460bbdd33400fe2c37b')
+fi
+
+source=(http://ftp.us.debian.org/debian/pool/main/p/pdfedit/pdfedit_${pkgver}-${_debpkgrel}_${_debarch}.deb)
+
+package() {
+ tar -xf data.tar.?z -C "$pkgdir" ./usr
+}
+
+# vim:set ts=2 sw=2 ft=sh et: