summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..070ebe852806
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Nov 17 16:49:57 UTC 2016
+pkgbase = pdfsandwich
+ pkgdesc = Wrapper for tesseract OCR and hocr2pdf to generate pdf files with the recognized text put behind the image (sandwich pdfs).
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = http://sourceforge.net/projects/pdfsandwich/
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ makedepends = ocaml
+ makedepends = gawk
+ depends = tesseract
+ depends = exact-image
+ depends = ghostscript
+ depends = unpaper
+ source = http://downloads.sourceforge.net/sourceforge/pdfsandwich/pdfsandwich-0.1.5.tar.bz2
+ sha512sums = SKIP
+
+pkgname = pdfsandwich
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcb657ce8563
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: petRUShka petrushkin at yandex dot ru
+# Contributor: Max Roder <maxroder@web.de>
+
+pkgname=pdfsandwich
+pkgver=0.1.5
+pkgrel=1
+pkgdesc="Wrapper for tesseract OCR and hocr2pdf to generate pdf files with the recognized text put behind the image (sandwich pdfs)."
+url="http://sourceforge.net/projects/pdfsandwich/"
+arch=('x86_64' 'i686')
+license=('GPL2')
+depends=('tesseract' 'exact-image' 'ghostscript' 'unpaper')
+makedepends=('ocaml' 'gawk')
+source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha512sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" PREFIX="/usr" install
+}
+
+# vim:set ts=2 sw=2 et: