summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3a524699a93..93e5aa8e4f55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo v8
+# Mon Jul 11 07:44:37 UTC 2016
pkgbase = pdsh
pkgdesc = Parallel Distributed Shell
- pkgver = 2.29
- pkgrel = 2
- url = http://code.google.com/p/pdsh/
+ pkgver = 2.31
+ pkgrel = 1
+ url = https://github.com/grondo/pdsh
arch = i686
arch = x86_64
license = GPL
@@ -11,8 +13,8 @@ pkgbase = pdsh
depends = readline
optdepends = perl: required by the dshbak utility
options = libtool
- source = http://pdsh.googlecode.com/files/pdsh-2.29.tar.bz2
- md5sums = e3512d03e491de6f1a735ab0ff702108
+ source = https://github.com/grondo/pdsh/archive/pdsh-2.31.tar.gz
+ md5sums = cab34b0ca78f3cf596fd648b265223ed
pkgname = pdsh
diff --git a/PKGBUILD b/PKGBUILD
index 5fc121b378dd..412e37206ad9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
# Contributor: sh0 <mee@sh0.org>
pkgname=pdsh
-pkgver=2.29
-pkgrel=2
+pkgver=2.31
+pkgrel=1
pkgdesc='Parallel Distributed Shell'
-url='http://code.google.com/p/pdsh/'
+url='https://github.com/grondo/pdsh'
arch=('i686' 'x86_64')
license=('GPL')
depends=('glibc' 'openssh' 'readline')
optdepends=('perl: required by the dshbak utility')
options=('libtool')
-source=("http://pdsh.googlecode.com/files/$pkgname-$pkgver.tar.bz2")
-md5sums=('e3512d03e491de6f1a735ab0ff702108')
+source=("https://github.com/grondo/pdsh/archive/pdsh-2.31.tar.gz")
+md5sums=('cab34b0ca78f3cf596fd648b265223ed')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
./configure --prefix=/usr --mandir=/usr/share/man \
--without-rsh \
--with-ssh \
@@ -25,7 +25,7 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}/" install || return 1
rmdir "${pkgdir}/usr/sbin"
}