summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
-rw-r--r--peda.install12
3 files changed, 16 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35884610277d..41386248ed25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,11 @@
+# Generated by mksrcinfo v8
+# Fri Jun 3 21:52:00 UTC 2016
pkgbase = peda-git
- pkgdesc = PEDA - Python Exploit Development Assistance for GDB
- pkgver = 71.1e62125
+ pkgdesc = Python Exploit Development Assistance for GDB
+ pkgver = 1.1.82.b7c7d7a
pkgrel = 1
+ epoch = 1
url = https://github.com/longld/peda
- install = peda.install
arch = any
license = custom:Creative Commons
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index c1392ed67bb9..b4ef46cec428 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,10 @@
pkgname=peda-git
_gitname=peda
-pkgver=71.1e62125
+pkgver=1.1.82.b7c7d7a
pkgrel=1
-pkgdesc="PEDA - Python Exploit Development Assistance for GDB"
+epoch=1
+pkgdesc='Python Exploit Development Assistance for GDB'
url='https://github.com/longld/peda'
arch=('any')
license=('custom:Creative Commons')
@@ -13,24 +14,27 @@ depends=( 'gdb' 'binutils' 'nasm' 'python-six')
makedepends=('git')
provides=('peda')
conflicts=('peda')
-install='peda.install'
-source=(${pkgname}::git+https://github.com/longld/${_gitname})
+source=(${pkgname}::git+https://github.com/longld/peda)
sha512sums=('SKIP')
pkgver() {
cd ${pkgname}
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0|sed -r 's|v?(.+)|\1|')" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd ${pkgname}
rm lib/six.py
+ sed '/git clone/d' -i README.md
+ sed 's|~/peda/peda.py|/usr/share/peda/peda.py|g' -i README.md
}
build() {
cd ${pkgname}
- python -m compileall .
- python -O -m compileall .
+ msg2 'Compiling python objects...'
+ python -m compileall . >/dev/null
+ python -O -m compileall . >/dev/null
}
package() {
diff --git a/peda.install b/peda.install
deleted file mode 100644
index 3614bcf9b31d..000000000000
--- a/peda.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- echo "
- >>> enable PEDA per user via:
- >>> echo 'source /usr/share/peda/peda.py' > ~/.gdbinit
- "
-}
-
-post_upgrade() {
- post_install
-}
-
-# vim: ts=2 sw=2 et: