summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
-rw-r--r--upnp-1.9.patch19
3 files changed, 8 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f70dd0b7e836..9d807689416d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Apr 28 09:01:31 UTC 2016
+# Fri May 6 11:08:45 UTC 2016
pkgbase = peerunity
pkgdesc = Community made Peercoin client.
- pkgver = 0.2.1
- pkgrel = 2
+ pkgver = 0.2.2
+ pkgrel = 1
url = https://github.com/Peerunity/Peerunity
arch = i686
arch = x86_64
@@ -18,15 +18,13 @@ pkgbase = peerunity
depends = openssl
depends = miniupnpc
depends = qt4
- source = https://github.com/peerunity/peerunity/archive/v0.2.1.tar.gz
- source = upnp-1.9.patch
+ source = https://github.com/peerunity/peerunity/archive/v0.2.2.tar.gz
source = peerunityd@.service
source = peerunityd-tor@.service
source = peerunity@.service
source = peerunity-tor@.service
source = peerunity.desktop
- sha256sums = b76ed814f19d7c2474801e4846c267a44059e09224f63ffe8686923c3d2deb31
- sha256sums = 3060917f8e327002da842534265392a1849239ec5049f25c1ae8a81c3952e7b1
+ sha256sums = 353079447ef2f03cfa740a23307e9b07240da12c6bb067cf1bf42347c887d210
sha256sums = 8d25b07ca8e3a7d972d584600a0083fe52b811efc0af0f98eba39c22cd173336
sha256sums = 5765241c7a1db1742cb034cd220cc65221f0c041299b9783ecc609aaa8ac120f
sha256sums = 7f8d2021ed95edb09971246e1fa578064057d7e4134c99558901d0d1960e80d9
diff --git a/PKGBUILD b/PKGBUILD
index 737e321258cd..c5bda50a10eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,34 +4,27 @@ pkgname=('peerunityd' 'peerunity')
pkgbase=peerunity
_gitname=Peerunity
pkgdesc="Community made Peercoin client."
-pkgver=0.2.1
-pkgrel=2
+pkgver=0.2.2
+pkgrel=1
arch=('i686' 'x86_64' 'armv7h' 'armv6h')
url="https://github.com/Peerunity/Peerunity"
makedepends=('boost' 'qrencode' 'miniupnpc' 'qt4')
depends=('boost-libs' 'openssl' 'miniupnpc' 'qt4')
license=('MIT')
source=("https://github.com/peerunity/peerunity/archive/v$pkgver.tar.gz"
- "upnp-1.9.patch"
"peerunityd@.service"
"peerunityd-tor@.service"
"peerunity@.service"
"peerunity-tor@.service"
"peerunity.desktop"
)
-sha256sums=('b76ed814f19d7c2474801e4846c267a44059e09224f63ffe8686923c3d2deb31'
- '3060917f8e327002da842534265392a1849239ec5049f25c1ae8a81c3952e7b1'
+sha256sums=('353079447ef2f03cfa740a23307e9b07240da12c6bb067cf1bf42347c887d210'
'8d25b07ca8e3a7d972d584600a0083fe52b811efc0af0f98eba39c22cd173336'
'5765241c7a1db1742cb034cd220cc65221f0c041299b9783ecc609aaa8ac120f'
'7f8d2021ed95edb09971246e1fa578064057d7e4134c99558901d0d1960e80d9'
'a9919759f080d09d1604962affc9117f444903ecddd0544e42ff291a0d05000d'
'250aa80695bbb95228286850856d1f1bac9336c98e884cba0b148c9b837d196c')
-prepare() {
- cd "$srcdir/${_gitname}-$pkgver"
- patch -p1 -i ../upnp-1.9.patch
-}
-
build() {
cd "$srcdir/${_gitname}-${pkgver}"
diff --git a/upnp-1.9.patch b/upnp-1.9.patch
deleted file mode 100644
index 42e6cf18e8d0..000000000000
--- a/upnp-1.9.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -Naur a/src/net.cpp b/src/net.cpp
---- a/src/net.cpp 2015-06-15 10:51:30.000000000 +0200
-+++ b/src/net.cpp 2015-10-03 16:15:10.441886309 +0200
-@@ -1020,10 +1020,14 @@
- #ifndef UPNPDISCOVER_SUCCESS
- /* miniupnpc 1.5 */
- devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0);
--#else
-+#elif MINIUPNPC_API_VERSION < 14
- /* miniupnpc 1.6 */
- int error = 0;
- devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, &error);
-+#else
-+ /* miniupnpc 1.9.20150730 */
-+ int error = 0;
-+ devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, 2, &error);
- #endif
-
- struct UPNPUrls urls;