summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc7484bddfc1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = peksystray
+ pkgdesc = Peksystray is a small system tray designed for all the light window managers supporting docking.
+ pkgver = 0.4.0
+ pkgrel = 6
+ url = http://sourceforge.net/projects/peksystray/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libx11
+ source = http://downloads.sourceforge.net/sourceforge/peksystray/peksystray-0.4.0.tar.bz2
+ md5sums = 735a216684f1db65bfe71697452cafc0
+
+pkgname = peksystray
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88b72a2a7f55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Brian Bidulock <bidulock@openss7.org>
+# Contributor: tyr0 <thomas.hoernes@gmx.at>
+pkgname=peksystray
+pkgver=0.4.0
+pkgrel=6
+pkgdesc="Peksystray is a small system tray designed for all the light window managers supporting docking."
+arch=(i686 x86_64)
+url="http://sourceforge.net/projects/peksystray/"
+license=('GPL')
+depends=('libx11')
+source=("http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2")
+md5sums=('735a216684f1db65bfe71697452cafc0')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure LIBS="-L/usr/lib/X11" --prefix=/usr \
+ --x-libraries="-lSM -lICE -lX11 -lXext"
+ make
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+