summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60c6a8a50482..8ab0988def4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Nov 30 17:47:23 UTC 2017
+# Mon Apr 16 05:36:02 UTC 2018
pkgbase = pencil2d
pkgdesc = An easy, intuitive tool to make 2D hand-drawn animations
- pkgver = 0.6.0
+ pkgver = 0.6.1
pkgrel = 1
url = https://pencil2d.org/
arch = x86_64
@@ -13,8 +13,10 @@ pkgbase = pencil2d
depends = qt5-xmlpatterns
depends = hicolor-icon-theme
depends = ffmpeg
- source = https://github.com/pencil2d/pencil/archive/0.6.0.tar.gz
- md5sums = 46ec6cb485b45ede9bd6a9728c9fc1a5
+ source = https://github.com/pencil2d/pencil/archive/v0.6.1.tar.gz
+ source = https://github.com/pencil2d/pencil/pull/946.patch
+ md5sums = 4a9804e7e2cdf37173bc8471dc5e21c8
+ md5sums = 0fb639286ec40bdc6d050487063a42da
pkgname = pencil2d
diff --git a/PKGBUILD b/PKGBUILD
index 5d262cc07100..7429a6a828a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,23 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=pencil2d
-pkgver=0.6.0
+pkgver=0.6.1
pkgrel=1
pkgdesc="An easy, intuitive tool to make 2D hand-drawn animations"
arch=('x86_64' 'i686')
url="https://pencil2d.org/"
license=('GPL2')
depends=('qt5-multimedia' 'qt5-svg' 'qt5-xmlpatterns' 'hicolor-icon-theme' 'ffmpeg')
-source=("https://github.com/pencil2d/pencil/archive/${pkgver}.tar.gz")
-md5sums=('46ec6cb485b45ede9bd6a9728c9fc1a5')
+source=("https://github.com/pencil2d/pencil/archive/v${pkgver}.tar.gz"
+ "https://github.com/pencil2d/pencil/pull/946.patch")
+md5sums=('4a9804e7e2cdf37173bc8471dc5e21c8'
+ '0fb639286ec40bdc6d050487063a42da')
+
+prepare() {
+ cd "${srcdir}/pencil-${pkgver}"
+
+ patch -Np1 < "${srcdir}/946.patch"
+}
build() {
cd "${srcdir}/pencil-${pkgver}"
@@ -22,5 +30,4 @@ package() {
cd "${srcdir}/pencil-${pkgver}"
make install INSTALL_ROOT="${pkgdir}"
- rm -rf "${pkgdir}/usr/lib"
}