summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c317b5657f7..e8a0c9f5bc14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pepys
pkgdesc = A straightforward markdown editor
- pkgver = 1.1.1
+ pkgver = 1.5.3
pkgrel = 1
url = https://www.lukebriggs.dev/pepys
arch = any
@@ -12,8 +12,8 @@ pkgbase = pepys
depends = pandoc
depends = enchant
depends = wkhtmltopdf
- depends = python-pyqt5
- depends = python-pyqt5-webengine
+ depends = python-pyqt6
+ depends = python-pyqt6-webengine
depends = python-regex
depends = python-pypandoc
depends = python-pyenchant
@@ -21,10 +21,11 @@ pkgbase = pepys
depends = python-pyaml
depends = aspell
depends = aspell-en
- source = https://github.com/LukeBriggsDev/Pepys/archive/refs/tags/v1.1.1.tar.gz
+ depends = python-cryptography
+ source = https://github.com/LukeBriggsDev/Pepys/archive/refs/tags/v1.5.3.tar.gz
source = https://files.pythonhosted.org/packages/33/db/76f1151a1b0cfad532d41021b77cd231495bf72c47618166f92dcdff2ebe/num2words-0.5.10.tar.gz
source = https://files.pythonhosted.org/packages/b4/01/68fcc0d43daf4c6bdbc6b33cc3f77bda531c86b174cac56ef0ffdb96faab/PyPDF2-1.26.0.tar.gz
- md5sums = 4bd2968cb4024cf485a12b2462ffa2ca
+ md5sums = 29e14e353d8805446be5a9d653d10b9b
md5sums = 1d0c24b6b789ad6bf91952d92cb6285f
md5sums = 2301acc0ecbab0633d4c9b883d50ee5e
diff --git a/PKGBUILD b/PKGBUILD
index cdcf0fc8b9be..47015cee6636 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Luke Briggs <lukebriggs02@gmail.com>
pkgname=pepys
-pkgver=1.1.1
+pkgver=1.5.3
pkgrel=1
epoch=
pkgdesc="A straightforward markdown editor"
@@ -10,7 +10,7 @@ arch=('any')
url="https://www.lukebriggs.dev/pepys"
license=('GPLv3')
groups=()
-depends=('python' 'python-wheel' 'python-pip' 'pandoc' 'enchant' 'wkhtmltopdf' 'python-pyqt5' 'python-pyqt5-webengine' 'python-regex' 'python-pypandoc' 'python-pyenchant' 'python-setproctitle' 'python-pyaml' 'aspell' 'aspell-en')
+depends=('python' 'python-wheel' 'python-pip' 'pandoc' 'enchant' 'wkhtmltopdf' 'python-pyqt6' 'python-pyqt6-webengine' 'python-regex' 'python-pypandoc' 'python-pyenchant' 'python-setproctitle' 'python-pyaml' 'aspell' 'aspell-en' 'python-cryptography')
makedepends=('python-setuptools')
checkdepends=()
optdepends=()
@@ -21,9 +21,9 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/LukeBriggsDev/Pepys/archive/refs/tags/v1.1.1.tar.gz" "https://files.pythonhosted.org/packages/33/db/76f1151a1b0cfad532d41021b77cd231495bf72c47618166f92dcdff2ebe/num2words-0.5.10.tar.gz" "https://files.pythonhosted.org/packages/b4/01/68fcc0d43daf4c6bdbc6b33cc3f77bda531c86b174cac56ef0ffdb96faab/PyPDF2-1.26.0.tar.gz")
+source=("https://github.com/LukeBriggsDev/Pepys/archive/refs/tags/v1.5.3.tar.gz" "https://files.pythonhosted.org/packages/33/db/76f1151a1b0cfad532d41021b77cd231495bf72c47618166f92dcdff2ebe/num2words-0.5.10.tar.gz" "https://files.pythonhosted.org/packages/b4/01/68fcc0d43daf4c6bdbc6b33cc3f77bda531c86b174cac56ef0ffdb96faab/PyPDF2-1.26.0.tar.gz")
noextract=()
-md5sums=('4bd2968cb4024cf485a12b2462ffa2ca' '1d0c24b6b789ad6bf91952d92cb6285f' '2301acc0ecbab0633d4c9b883d50ee5e')
+md5sums=('29e14e353d8805446be5a9d653d10b9b' '1d0c24b6b789ad6bf91952d92cb6285f' '2301acc0ecbab0633d4c9b883d50ee5e')
validpgpkeys=()
@@ -43,7 +43,7 @@ package() {
mkdir -p $pkgdir/usr/share/pepys
mkdir -p $pkgdir/usr/local/share/applications
mkdir -p $pkgdir/usr/bin
- mv Pepys-1.1.1/src $pkgdir/usr/share/pepys
+ mv Pepys-1.5.3/src $pkgdir/usr/share/pepys
# Create desktop entry
echo "[Desktop Entry]
Type=Application