summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD74
2 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..588fcd1b6638
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = perl-app-rad
+ pkgdesc = App::Rad - Rapid (and easy!) creation of command line applications
+ pkgver = 1.05
+ pkgrel = 1
+ url = http://search.cpan.org/dist/App-Rad/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ provides = perl-app-rad-config
+ provides = perl-app-rad-exclude
+ provides = perl-app-rad-help
+ provides = perl-app-rad-include
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/G/GA/GARU/App-Rad-1.05.tar.gz
+ md5sums = 407c3d4f8343a2c4337d5c351fd46a91
+
+pkgname = perl-app-rad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a885bd3ad52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+
+pkgname=perl-app-rad
+pkgver=1.05
+pkgrel=1
+_author="G/GA/GARU"
+_perlmod="App-Rad"
+pkgdesc="App::Rad - Rapid (and easy!) creation of command line applications"
+arch=('any')
+url="http://search.cpan.org/dist/App-Rad/"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0')
+provides=(
+perl-app-rad-config
+perl-app-rad-exclude
+perl-app-rad-help
+perl-app-rad-include
+)
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+noextract=()
+
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+md5sums=('407c3d4f8343a2c4337d5c351fd46a91')