summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa26377a7b35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-astro-telescope
+ pkgdesc = Astro::Telescope - class for obtaining telescope information
+ pkgver = 0.71
+ pkgrel = 1
+ url = https://metacpan.org/release/Astro-Telescope
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ options = purge
+ source = https://cpan.metacpan.org/authors/id/T/TJ/TJENNESS/Astro-Telescope-0.71.tar.gz
+ md5sums = b1bd791667a18be7621b2aa5d6534a38
+
+pkgname = perl-astro-telescope
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d24dec79d318
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Troy Will <.com .gmail AT troydwill>
+pkgname=perl-astro-telescope
+pkgver=0.71
+pkgrel=1
+pkgdesc='Astro::Telescope - class for obtaining telescope information'
+_dist=Astro-Telescope
+_author=T/TJ/TJENNESS
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
+depends=(perl)
+options=('!emptydirs' purge)
+source=("https://cpan.metacpan.org/authors/id/$_author/$_dist-$pkgver.tar.gz")
+md5sums=(b1bd791667a18be7621b2aa5d6534a38)
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 MODULEBUILDRC=/dev/null
+ /usr/bin/perl Build.PL
+ ./Build
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ ./Build test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
+}