summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
-rw-r--r--PKGBUILD.tt10
3 files changed, 27 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5f9f0b031c7..2c7003ab8136 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = perl-autodie
pkgdesc = Replace functions with ones that succeed or die with lexical scope
- pkgver = 2.32
+ pkgver = 2.34
pkgrel = 1
url = https://metacpan.org/release/autodie
arch = any
@@ -8,8 +8,8 @@ pkgbase = perl-autodie
license = GPL
depends = perl>=5.8.8
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/autodie-2.32.tar.gz
- md5sums = 8e28b6c0eea1d8d79407e23de270db3c
+ source = http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/autodie-2.34.tar.gz
+ md5sums = e1d9609ed1655f951151ee4cd2a14fa4
pkgname = perl-autodie
diff --git a/PKGBUILD b/PKGBUILD
index 10c2705e1a39..a7a08c62ea7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,38 @@
# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-autodie
-pkgver=2.32
+pkgver=2.34
pkgrel=1
pkgdesc='Replace functions with ones that succeed or die with lexical scope'
arch=('any')
url='https://metacpan.org/release/autodie'
license=('PerlArtistic' 'GPL')
depends=('perl>=5.8.8')
-source=(http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/autodie-2.32.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/autodie-2.34.tar.gz)
options=(!emptydirs)
-md5sums=('8e28b6c0eea1d8d79407e23de270db3c')
+md5sums=('e1d9609ed1655f951151ee4cd2a14fa4')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+}
build() {
- cd autodie-2.32
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ cd autodie-2.34
+ sanitize
+ perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd autodie-2.32
+ cd autodie-2.34
+ sanitize
make test
}
package() {
- cd autodie-2.32
+ cd autodie-2.34
+ sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index de354deb0a88..d1b938a3f9eb 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -14,19 +14,27 @@ source=([% source %])
options=(!emptydirs)
md5sums=('[% md5sums %]')
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+}
+
build() {
cd [% distdir %]
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ sanitize
+ perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
cd [% distdir %]
+ sanitize
make test
}
package() {
cd [% distdir %]
+ sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}