summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD32
-rw-r--r--PKGBUILD.tt32
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cb2d6f07323
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-b-hooks-op-annotation
+ pkgdesc = Perl module that allows XS modules to annotate and delegate hooked OPs
+ pkgver = 0.44
+ pkgrel = 1
+ url = http://search.cpan.org/dist/B-Hooks-OP-Annotation
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ depends = perl-extutils-depends>=0.304
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/C/CH/CHOCOLATE/B-Hooks-OP-Annotation-0.44.tar.gz
+ md5sums = 18b1f0088850effe58ccb4a7c9dc4024
+
+pkgname = perl-b-hooks-op-annotation
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02a97d5cf69f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# CPAN Name : B::Hooks::OP::Annotation
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.19
+
+pkgname=perl-b-hooks-op-annotation
+pkgver=0.44
+pkgrel=1
+pkgdesc="Perl module that allows XS modules to annotate and delegate hooked OPs"
+arch=("i686" "x86_64")
+url="http://search.cpan.org/dist/B-Hooks-OP-Annotation"
+license=("PerlArtistic" "GPL")
+depends=("perl" "perl-extutils-depends>=0.304")
+source=(http://search.cpan.org/CPAN/authors/id/C/CH/CHOCOLATE/B-Hooks-OP-Annotation-0.44.tar.gz)
+options=(!emptydirs)
+md5sums=("18b1f0088850effe58ccb4a7c9dc4024")
+
+build() {
+ cd "$srcdir/B-Hooks-OP-Annotation-0.44"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/B-Hooks-OP-Annotation-0.44"
+ make test
+}
+
+package() {
+ cd "$srcdir/B-Hooks-OP-Annotation-0.44"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..5bf321f45f9b
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,32 @@
+# CPAN Name : B::Hooks::OP::Annotation
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc="Perl module that allows XS modules to annotate and delegate hooked OPs"
+arch=("i686" "x86_64")
+url="[% url %]"
+license=("PerlArtistic" "GPL")
+depends=("perl" "perl-extutils-depends>=0.304")
+source=([% source %])
+options=(!emptydirs)
+md5sums=("[% md5sums %]")
+
+build() {
+ cd "$srcdir/[% distdir %]"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/[% distdir %]"
+ make test
+}
+
+package() {
+ cd "$srcdir/[% distdir %]"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}