summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD79
2 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01d8e7d17774
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = perl-bash-completion
+ pkgdesc = Bash::Completion - Extensible system to provide bash completion
+ pkgver = 0.008
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Bash-Completion/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ checkdepends = perl-test-deep
+ depends = perl-list-moreutils
+ depends = perl-module-pluggable
+ optdepends = perl-bash-completion-plugins-: install plugins that you need
+ provides = perl-app-bashcomplete
+ provides = perl-bash-completion-plugin
+ provides = perl-bash-completion-plugins-bashcomplete
+ provides = perl-bash-completion-plugins-perldoc
+ provides = perl-bash-completion-request
+ provides = perl-bash-completion-utils
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/M/ME/MELO/Bash-Completion-0.008.tar.gz
+ md5sums = fcb7e1c405d1a193fb7fa8cbe22fda37
+
+pkgname = perl-bash-completion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b829d7e19b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+
+pkgname=perl-bash-completion
+pkgver=0.008
+pkgrel=1
+_author="M/ME/MELO"
+_perlmod="Bash-Completion"
+pkgdesc="Bash::Completion - Extensible system to provide bash completion"
+arch=('any')
+url="http://search.cpan.org/dist/Bash-Completion/"
+license=('GPL' 'PerlArtistic')
+depends=(
+perl-list-moreutils
+perl-module-pluggable
+)
+checkdepends=(perl-test-deep)
+provides=(
+perl-app-bashcomplete
+perl-bash-completion-plugin
+perl-bash-completion-plugins-bashcomplete
+perl-bash-completion-plugins-perldoc
+perl-bash-completion-request
+perl-bash-completion-utils
+)
+optdepends=('perl-bash-completion-plugins-: install plugins that you need')
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+
+ install -dm755 "$pkgdir"/etc/bash_completion.d
+ ln -s /usr/bin/vendor_perl/setup-bash-complete "$pkgdir"/etc/bash_completion.d/perl-bash-completion
+}
+
+md5sums=('fcb7e1c405d1a193fb7fa8cbe22fda37')